2

I've installed Oracle Linux 6 and Oracle 12c.

I don't remember if I've configured crontab to launch some script or not, but during the system's booting, it stops just after crond daemon has been started.

I've also tried booting with different kernels.

System stops loading after crond daemon starting

I could not access the system.

Is there a way to skip crond daemon starting without access to system configuration?

2
  • 1
    being rhel 6 with sysinit and not systemd you can skip crond during boot by having done a chkconfig <service> off then rebooting allowing the normal boot process. You would need to first need to interrupt the normal boot and make it boot to single user mode to do chkconfig crond off then reboot allowing normal boot process to runlevel 3 or 5.
    – ron
    Nov 18, 2019 at 15:03
  • It seems that crond service is not responsible for this behavior. I've tried disabling it also, but it stops booting further after tuned service starting. Something else prevents system from proper booting. Thank you!
    – Gryu
    Nov 18, 2019 at 15:38

1 Answer 1

2

It looks like crond has started successfully: the problem might be with whatever comes after crond. Or it might be triggered by something crond starts up.

Note that sshd has already started and network parameters have already been set, so you should be able to login with SSH.

If that does not work, the kernel may be hung. To troubleshoot, interrupt the automatic boot at the GRUB menu, and add a boot option (e.g. single) to boot the system into a minimal state ("single user mode"), omitting services like crond.

After doing that, maybe first check /var/log/messages, just in case there is a problem that causes log messages to be recorded but fails to display them.

Classically, the start-up scripts in /etc/rc3.d would be executed in alphanumerical order and comparing your boot messages on your screenshot to the contents of /etc/rc3.d on my RHEL VM looks like the order does match... so, run ls /etc/rc3.d and see what scripts come after S90crond on your installation if you need to know what would be the next steps in the start-up process.

1
  • Thank you! Yes, I could log in through ssh. I've deleted crontab's record I've added earlier. After reboot booting stops at the same point. But it is good enough that I could move further. I was thinking that crond starts that script and it prevents further booting. But this thought of mine was wrong.
    – Gryu
    Nov 18, 2019 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.