1

I have recently upgraded my 2007 MacBook using this tutorial, which installs Debian 8. I had successfully installed it, and was running Debian 8, but needed to change my trackpad speed beyond the system settings maximum (accessed with the settings GUI). So I took to Google and found the marvellous xinput. I ran xinput list, and a bunch of different items came up (there were about 20 from memory). And they all had intuitive names.

I saw the one I wanted to change: appletouch. So I ran xinput --list-props appletouch and I found the acceleration speed, which was set to 12.5 by default (I could not find a plain speed setting). I changed it to 20 and didn't feel much difference (I was rebooting between changes as I wasn't sure if it would take effect immediately or not). Then to 40, then to 60. 60 seems quite high, but it worked for what I needed, so I kept it as that.

Then I realised I could upgrade to Debian 9, so I did, and that was all fine. Then I realised that I could upgrade again, to Debian 10, so I have done that. However, now it really does feel like my touchpad acceleration is at 60, as I can keep my finger relatively still on the touchpad and it starts jittering around. The only way it is usable is if I have my mouse speed on very low, or else there is no accuracy to where I am clicking.

So to fix this, I took to xinput again. However, I could not find appletouch or anything of the like. This was my output:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer:15                   id=6    [slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:15          id=7    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
    ↳ xwayland-keyboard:15                  id=8    [slave  keyboard (3)]

This isn't very intuitive anymore, and there are considerably fewer configuration options. After having a look, it looks like 6 and 7 may be what I need to change. However, I have changed these, and nothing has changed in terms of the feel of the trackpad.

The output when running xinput --list-props 6 (which is the same output at 7) is (omitting quite a few decimal places)

Device Enabled (115): 1
Coordinate Transformation Matrix (117): 1, 0, 0, 0, 1, 0, 0, 0, 1
Device Accel Profile (240): 0
Device Accel Constant Deceleration (241): 1
Device Accel Adaptive Deceleration (242): 1
Device Accel Velocity Scaling (243): 10

What strikes me is that there is no option that feels like it is acceleration 60... I can set xinput --set-prop 6 231 1 and it will change, but when I reboot it is set back to normal (and at no point does anything feel different).

Help would be very much appreciated, as I don't know what to do to change this

1

Since Version 10 Debian uses Wayland so afaik you can't use xinput. I never tried it but maybe libinput helps in this regard.


I found the acceleration speed, which was set to 12.5 by default (I could not find a plain speed setting)

You can also change the speed by modifying the transformation matrix:

xinput set-prop <your-device-id> "Coordinate Transformation Matrix" 0.3 0 0 0 0.3 0 0 0 1

Also if the pointer is jittery try to set "Noise cancelling" to a higher value if your driver supports this property.

To retain changes made by xinput after restart put the commands into .xsessionrc in your home dir. Create the file if necessary.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.