1

I have gedit set as my git editor, and it works quite well for me. When I do git commit, gedit pops up with the commit info and I can enter my commit message, Ctrl+S, Ctrl+Q and git will proceed as expected.

However, because git commit and hence the gedit was run from the commandline, it keeps printing some garbage errors to the terminal while running:

(gedit:13464): Gtk-CRITICAL **: 14:34:01.231: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(gedit:13464): Gtk-CRITICAL **: 14:34:06.108: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(gedit:13464): Gtk-CRITICAL **: 14:34:07.616: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(gedit:13464): Gtk-CRITICAL **: 14:34:13.934: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

Although the errors are marked critical, I experience no actual issues in gedit. The errors, however, do critically clutter up my terminal whereas I'd rather be seeing more interesting output/shell history instead (Yes, I know I can scroll up, that's not the point), such as the result of git status that I called just before git commit.

Why are these errors being printed? In this case, it's clearly some GTK issue, but I don't really care - how can I make gedit shut up about it?

I'm on Debian 10 and my gtk packages are:

albatross-gtk-theme/now 1.7.4-1 all [installed,local]
blackbird-gtk-theme/testing,now 0.4+20160704~ab4a30e-1 all [installed,automatic]
bluebird-gtk-theme/testing,now 1.3-1 all [installed,automatic]
fcitx-config-gtk/testing,now 0.4.10-2 amd64 [installed,automatic]
fcitx-frontend-gtk2/now 1:4.2.9.6-5 amd64 [installed,upgradable to: 1:4.2.9.6-6]
fcitx-frontend-gtk3/now 1:4.2.9.6-5 amd64 [installed,upgradable to: 1:4.2.9.6-6]
gedit-common/now 3.30.2-2 all [installed,upgradable to: 3.34.0-1]
gedit-plugin-bookmarks/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-bracket-completion/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-character-map/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-code-comment/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-color-picker/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-color-schemer/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-commander/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-draw-spaces/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-find-in-files/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-git/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-join-lines/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-multi-edit/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-smart-spaces/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-synctex/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-terminal/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-translate/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-word-completion/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugin-zeitgeist/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugins-common/now 3.30.1-3 amd64 [installed,upgradable to: 3.34.0-3]
gedit-plugins/now 3.30.1-3 all [installed,upgradable to: 3.34.0-3]
gedit/now 3.30.2-2 amd64 [installed,upgradable to: 3.34.0-1]
gir1.2-gtk-3.0/now 3.24.5-1 amd64 [installed,upgradable to: 3.24.12-1]
gir1.2-gtkclutter-1.0/testing,now 1.8.4-4 amd64 [installed,automatic]
gir1.2-gtksource-3.0/now 3.24.9-2 amd64 [installed,upgradable to: 3.24.11-2]
gir1.2-javascriptcoregtk-4.0/now 2.24.3-1~deb10u1 amd64 [installed,upgradable to: 2.26.1-3]
greybird-gtk-theme/testing,now 3.22.10-1 all [installed,automatic]
gstreamer1.0-gtk3/now 1.14.4-1 amd64 [installed,upgradable to: 1.16.1-1]
gtk-update-icon-cache/now 3.24.5-1 amd64 [installed,upgradable to: 3.24.12-1]
gtk2-engines-murrine/testing,now 0.98.2-2 amd64 [installed,automatic]
gtk2-engines-pixbuf/now 2.24.32-3 amd64 [installed,upgradable to: 2.24.32-4]
gtk2-engines/testing,now 1:2.20.2-5 amd64 [installed,automatic]
ibus-gtk3/now 1.5.19-4 amd64 [installed,upgradable to: 1.5.19-4+b1]
ibus-gtk/now 1.5.19-4 amd64 [installed,upgradable to: 1.5.19-4+b1]
libavahi-ui-gtk3-0/testing,now 0.7-4+b1 amd64 [installed,automatic]
libcanberra-gtk3-0/testing,now 0.30-7 amd64 [installed,automatic]
libcanberra-gtk3-module/testing,now 0.30-7 amd64 [installed,automatic]
libcheese-gtk25/now 3.31.90-1 amd64 [installed,upgradable to: 3.34.0-1+b1]
libclutter-gtk-1.0-0/testing,now 1.8.4-4 amd64 [installed,automatic]
libcolord-gtk1/testing,now 0.1.26-2 amd64 [installed,automatic]
libdbusmenu-gtk3-4/testing,now 18.10.20180917~bzr490+repack1-1 amd64 [installed,automatic]
libdbusmenu-gtk4/testing,now 18.10.20180917~bzr490+repack1-1 amd64 [installed,automatic]
libgtk-3-0/now 3.24.5-1 amd64 [installed,upgradable to: 3.24.12-1]
libgtk-3-bin/now 3.24.5-1 amd64 [installed,upgradable to: 3.24.12-1]
libgtk-3-common/now 3.24.5-1 all [installed,upgradable to: 3.24.12-1]
libgtk-vnc-2.0-0/now 0.9.0-1.1 amd64 [installed,upgradable to: 0.9.0-1.1+b1]
libgtk2.0-0/now 2.24.32-3 amd64 [installed,upgradable to: 2.24.32-4]
libgtk2.0-bin/now 2.24.32-3 amd64 [installed,upgradable to: 2.24.32-4]
libgtk2.0-common/now 2.24.32-3 all [installed,upgradable to: 2.24.32-4]
libgtkmm-2.4-1v5/testing,now 1:2.24.5-4 amd64 [installed,automatic]
libgtkmm-3.0-1v5/now 3.24.0-2 amd64 [installed,upgradable to: 3.24.2-1]
libgtksourceview-3.0-1/now 3.24.9-2 amd64 [installed,upgradable to: 3.24.11-2]
libgtksourceview-3.0-common/now 3.24.9-2 all [installed,upgradable to: 3.24.11-2]
libgtksourceviewmm-3.0-0v5/testing,now 3.18.0-4 amd64 [installed,automatic]
libgtkspell0/now 2.0.16-1.2 amd64 [installed,upgradable to: 2.0.16-1.2+b1]
libgtkspell3-3-0/testing,now 3.0.9-3 amd64 [installed,automatic]
libjavascriptcoregtk-4.0-18/now 2.24.3-1~deb10u1 amd64 [installed,upgradable to: 2.26.1-3]
libreoffice-gtk3/now 1:6.1.5-3+deb10u3 amd64 [installed,upgradable to: 1:6.3.3-2]
libspice-client-gtk-3.0-5/now 0.35-2 amd64 [installed,upgradable to: 0.37-1]
libwebkit2gtk-4.0-37/now 2.24.3-1~deb10u1 amd64 [installed,upgradable to: 2.26.1-3]
libwxgtk3.0-gtk3-0v5/testing,now 3.0.4+dfsg-15 amd64 [installed,automatic]
lightdm-gtk-greeter/testing,now 2.0.6-1 amd64 [installed,automatic]
qalculate-gtk/testing,now 2.8.2-1 amd64 [installed,automatic]
qt5-gtk-platformtheme/testing,now 5.12.5+dfsg-2 amd64 [installed,automatic]
transmission-gtk/now 2.94-2 amd64 [installed,upgradable to: 2.94-2+b1]
uim-gtk2.0-immodule/testing,now 1:1.8.8-6+b1 amd64 [installed,automatic]
uim-gtk2.0/testing,now 1:1.8.8-6+b1 amd64 [installed,automatic]
uim-gtk3-immodule/testing,now 1:1.8.8-6+b1 amd64 [installed,automatic]
uim-gtk3/testing,now 1:1.8.8-6+b1 amd64 [installed,automatic]
xdg-desktop-portal-gtk/testing,now 1.4.0-2 amd64 [installed,automatic]
xdg-user-dirs-gtk/testing,now 0.10-3 amd64 [installed,automatic]
3
  • Please, add the system that your are using and the result of rpm -qa | grep -i gtk – alessiosavi Nov 15 '19 at 7:55
  • @alessiosavi Added my distro - I don't have rpm and grep -i gtk seems to hang. – Donentolon Nov 15 '19 at 18:28
  • sudo apt list --installed | egrep -i "gedit|gtk" for debian – alessiosavi Nov 16 '19 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.