I am trying to install Linux dual booted with Windows on my computer. I am interested in networking so after researching online a bit, I wanted to install Kali.

After getting a Live USB loaded up, I followed all of the instructions on these two pages.

Everything worked perfectly up until the end. I rebooted and got an error:

Welcome to GRUB!
error: file '/boot/grub/x86-64-efi/normal.mod' not found.
grub rescue>

As I am completely new to linux, can someone explain me what I did wrong during the installation?

I installed the large package, verified the hash, wrote the ISO to a USB and allocated 35GB of my SSD to Kali. I followed all of the steps exactly as prescribed on the help page.

I researched online a bit about people getting similar errors, and everyone seems to get an error with 'i386-pc' instead. Also, in my Live USB, install-grub is not an available command (by default).


From Kali Linux documentation (emphasis mine):

Is Kali Linux Right For You?

As the distribution’s developers, you might expect us to recommend that everyone should be using Kali Linux. The fact of the matter is, however, that Kali is a Linux distribution specifically geared towards professional penetration testers and security specialists, and given its unique nature, it is NOT a recommended distribution if you’re unfamiliar with Linux or are looking for a general-purpose Linux desktop distribution for development, web design, gaming, etc.

Even for experienced Linux users, Kali can pose some challenges. [...]

Kali tends to be more "bleeding-edge" (i.e. newer stuff, even at the risk that something occasionally breaks) than the mainstream distributions. It is my opinion that you made a bad choice when you picked Kali as your first Linux installation.

The error message indicates you're using an UEFI version of the GRUB bootloader, so you must have a fairly modern system with UEFI firmware. The installation instructions you linked unfortunately only cover the case of legacy BIOS-style bootloader (which is also what the i386-pc would refer to). With the UEFI version, the screenshot in step #14 should be somewhat different, as "master boot record" does not really apply with UEFI.

In your EFI System Partition, there should now be a directory \EFI\kali (or possibly \EFI\debian), which should contain several files, including grubx64.efi = the actual GRUB bootloader, and grub.cfg = the initial configuration file for it. There should also be a \EFI\Microsoft directory containing the Windows bootloader, if Windows is also using the UEFI boot style.

The grub.cfg file should contain something like the following:

search.fs_uuid 12345678-9abc-def0-1234-56789abcdef0 root 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

The UUID string on the search.fs_uuid line would refer to the filesystem UUID of the GPT partition you installed Kali onto (either the Kali root filesystem, or the /boot filesystem if you created it as a separate partition), and the set prefix line should refer to the directory containing the GRUB modules directory (x86-64-efi for the UEFI version of GRUB) and the actual GRUB configuration file on that partition. All of these should have been determined automatically by the installer based on the choices you made previously, and unfortunately it looks like the Kali installer got some of it wrong for some reason, or failed to populate the actual GRUB modules directory correctly. To fix the boot problem, you would have to verify that this information matches the reality of your installation, and correct as necessary.

So unless you specified to create multiple partitions for Kali and specified a too-small size for one of them, it looks like you might not have done anything wrong and got the error through no fault of yours.

In order to diagnose, it would be important to see a view of your current disk partitioning (with gparted or something similar). The information displayed by gparted's Partition -> Information menu item for any partition generated by the Kali installer would also be useful, as it includes the UUID field that should match what is in the grub.cfg file placed into the EFI System Partition.

I haven't checked Kali Live USB specifically, but generally the command to install GRUB would be grub-install, not install-grub.

  • Thank you so much for your response. When I read it, I thought to myself that I might as well try a clean re-install to see if this would work. So I wiped my partition and started over again. While performing the exact same process, this time GRUB installed succesfully. I ran into another issue of the screen turning grey after logging in, but this was quickly fixed by reinstalling lightdm from the terminal. Though now I see, I might need to reevaluate my decision on Kali and perhaps opt for another distro. – user2988879 Nov 14 '19 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.