2

after upgrading to Ubuntu 19.04 I frequently got a 'failed to register the EFI boot entry: Function not implemented.' error when installing new packages. Now I updated to Ubuntu 19.10 and the installation first aborted because of my system being 'unstable'. After executing 'apt-get upgrade' the next time the system upgraded anyway.

Now when I run 'sudo apt-get upgrade' I get:

[...]

Do you want to continue? [Y/n] y
Setting up grub-efi-amd64-signed (1.128+2.04-1ubuntu12) ...
Installing for x86_64-efi platform.
grub-install: warning: efivarfs_get_variable: open(/sys/firmware/efi/efivars/blk0-47c7b225-c42a-11d2-8e57-00a0c969723b): No such file or directory.
grub-install: warning: efi_get_variable: ops->get_variable failed: No such file or directory.
grub-install: warning: device_get: readlink of /sys/block/nvme0n1/device/driver failed: No such file or directory.
grub-install: warning: is_gpt_valid: GUID Partition Table Header signature is wrong: 0 != 5452415020494645: Invalid argument.
grub-install: warning: is_gpt_valid: GUID Partition Table Header signature is wrong: 0 != 5452415020494645: Invalid argument.
grub-install: warning: msdos_disk_get_extended_partition_info: extended partition info is not supported: Function not implemented.
grub-install: warning: msdos_disk_get_partition_info: could not get extended partition info: Function not implemented.
grub-install: warning: get_partition_info: neither MBR nor GPT is valid: Function not implemented.
grub-install: warning: make_hd_dn: could not get partition info: Function not implemented.
grub-install: warning: efi_va_generate_file_device_path_from_esp: could not make HD() DP node: Function not implemented.
grub-install: warning: efi_generate_file_device_path_from_esp: could not generate File DP from ESP: Function not implemented.
grub-install: error: failed to register the EFI boot entry: Function not implemented.
dpkg: error processing package grub-efi-amd64-signed (--configure):
 installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 grub-efi-amd64-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)

So now some additional warnings appear. I can use my system with no apparent restrictions but after reading during the 19.10 upgrade that my system may be unstable I want to check how to fix this issue.

Would be great if someone knows a solution.

1

I've had this same issue, and unfortunately can only help you with a temporary solution. Perhaps somebody else can later add a definite solution. In my case I could anticipate this by:

  1. After your update, keep your terminal window open. If you didn't use your command line for updating, open terminal (CTRL+ALT+T).
  2. Now open your Partition Manager (e.g. GParted).
  3. In GParted, unmount your EFI System Partition (/efi/boot)
  4. Go back to your terminal, and type sudo apt install -f followed by an Enter
  5. When this has finished, go back to GParted and mount your EFI System Partition (/efi/boot)
  6. If you now do sudo apt update && sudo apt upgrade in terminal (again), your errors should be gone.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.