0

I have a centos 7 server and i am trying to install a certain package but i am getting error package and the package names are all .el8 but i dont understand why this is the case? There is no epel8 in my repo list:

repo id                                                    repo name                                                                                       status
base/7/x86_64                                              CentOS-7 - Base                                                                                 10,097
epel/x86_64                                                Extra Packages for Enterprise Linux 7 - x86_64                                                  13,455
extras/7/x86_64                                            CentOS-7 - Extras                                                                                  305
salt-latest/x86_64                                         SaltStack Latest Release Channel for RHEL/Centos 7                                                 107
salt-py3-2019.2/x86_64                                     SaltStack 2019.2 Release Channel for Python 3 RHEL/Centos 7                                         84
saltstack/x86_64                                           SaltStack latest Release Channel for RHEL/CentOS 7                                                 107
updates/7/x86_64                                           CentOS-7 - Updates                                                                                 711
repolist: 24,866

Can i force epel7?

Output for the errors

Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-markupsafe
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1()(64bit)
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libssl.so.1.1()(64bit)
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-pyyaml
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libssl.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-requests
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-six
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-jinja2
Error: Package: salt-master-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-systemd
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit)
  • The first issue I see is that you have three separate SaltStack repositories installed, pare that down to just the one you need. If you can show the output of rpm -qf $(grep -H 'baseurl\|mirror' $(grep -HRl salt /etc/yum.repos.d/) | tee /dev/stderr | awk -F: '{print $1}'), we may be able to determine where the problem is. – GracefulRestart Nov 13 '19 at 18:12
0

Removed the three salt-stack repo's which as mentioned caused the issue. Install ran fine after that. in the folder /etc/yum.repos.d/ Removed the three salt repos Installed a single repo relating to salt. ran the install script again and it no longer errors on the packages.

|improve this answer|||||
  • No looks like an answer – Tejas Nov 14 '19 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.