1

I am using Mint 19.2, based on Ubuntu 18.

I uninstalled using apt purge & then deleting the folder. Finally, reinstalled Docker using the commands from the official site.

However when I run the command docker -v or sudo docker -v, I get the response:

command not found: docker

When I run the command: sudo apt-get install docker-ce docker-ce-cli containerd.io, I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
containerd.io is already the newest version (1.2.10-3).
docker-ce-cli is already the newest version (5:19.03.4~3-0~ubuntu-bionic).
docker-ce is already the newest version (5:19.03.4~3-0~ubuntu-bionic).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

enter image description here

How can I rectify this & make docker accessible globally?

4
  • Does sudo docker -v return anything? – kemotep Nov 13 '19 at 14:59
  • @kemotep no. Still command not found. – Kayote Nov 13 '19 at 15:17
  • To be clear, you followed all the steps specified in this link from your post and sudo docker run hello-world does not work either? If you note on that page it says that untested and unsupported ports of docker are not expected to work. If you follow this advice for installing docker on Mint you need to add the Ubuntu repos for this to work. Have you done that? – kemotep Nov 13 '19 at 15:58
  • @kemotep Yes, I installed using Ubuntu version 'Bionic', based of which, Mint is installed. – Kayote Nov 13 '19 at 16:09
1

I think the issue was that there was conflict & the system had'nt removed docker properly, even though I followed the instructions as per the official site.

However, what worked for me was purging everything docker related.

sudo apt-get purge docker-ce docker-ce-cli containerd.io docker-compose

Then I removed the docker folder from /var/lib folder.

Rebooted for surety. Then reinstalled as per the official docs again.

And after reboot again, it worked.

Dont forget, docker-compose needs to be installed separately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.