0

I am having a major problem with the Arch Linux installer ISO (archiso). On my UEFI computer, it does boot from the USB, however I see a lot of errors, and about 5 pages of code spam the screen before it gets to the "automatic login" part. And then, when it finally gets to the login part, 4 more errors appear on the screen. These errors are so precise and long, I can't even notice what they are exactly saying. Furthermore, I cannot connect to Wi-Fi after it does boot, since my only Wi-Fi interface (wlp2s0) does not show. I feel like this is a problem with my computer itself, because I have troubleshooted with all the following:

  • Same problem when ISO is written on a different USB pen.
  • All other distros' ISOs boot fine on the same installation media: Debian and Ubuntu work perfectly.
  • The same archiso installation media boots perfectly correctly on my other computer, which also uses UEFI.
  • I never had this problem before; it worked perfectly fine before. It's only recently it's come about

So, because of this, I tried the following to resolve it:

  • Clearing the UEFI NVRAM
  • Re-flashing the UEFI Firmware (yes, I even went this far!)

And after all of this, it still doesn't work. I don't know what to do. If Wi-Fi breaks I don't want to even begin to think what other hardware breaks!

EDIT: Output of dmesg:

Since the output is very long, I have logged it all to a text file, accessible from here:

Google Drive Link

6
  • After you log in, you should have dmesg available, so you can show us what are the exact errors you're getting.
    – schaiba
    Nov 13, 2019 at 8:07
  • @schaiba Question edited to include it.
    – Daniel M.
    Nov 13, 2019 at 16:15
  • Use dmesg | less, which will show output one screen at a time, then, if you can't paste, take pictures and add the link to them. That video is not of much use.
    – schaiba
    Nov 13, 2019 at 18:46
  • @schaiba I have managed to log dmesg into a text file, which I have edited the question to link to instead of the video.
    – Daniel M.
    Nov 13, 2019 at 20:39
  • So you have a Chromebook. The Arch wiki has an entry for those devices here : wiki.archlinux.org/index.php/Chrome_OS_devices
    – schaiba
    Nov 14, 2019 at 7:51

0

You must log in to answer this question.

Browse other questions tagged .