2

kglobalaccel5, a keyboard shortcut service, keeps chrashing and taking the whole session down with it. Apparently, it has been unstable for quite a while. I don't really need the shortcuts, so killing the process seems to fix it for me.

However, it is spawned automatically at login and respawns after logging in. Is there a way to disable it altogether?

Update It seems to be a dbus service:

# cat /usr/share/dbus-1/services/org.kde.kglobalaccel.service
[D-BUS Service]
Name=org.kde.kglobalaccel
Exec=/usr/bin/kglobalaccel5

I'm still not sure how to turn it off though. However since I've started killing it after logging in, I didn't experience any crashes.

While it was running, it could find the following:

# pstree -s -p $pid
systemd(1)───systemd(1872)───kglobalaccel5(9450)─┬─{kglobalaccel5}(9451)
                                                 └─{kglobalaccel5}(9452)
# systemctl status 9450 | grep kglobal
               ├─dbus\x2d:1.2\x2dorg.kde.kglobalaccel.slice
               │ └─dbus-:1.2-org.kde.kglobalaccel@4.service
               │   └─9450 /usr/bin/kglobalaccel5

Fedora 31, KDE

Bugreport with equivalent backtrace: https://bugs.archlinux.org/task/63280

One of the bugreports as reference: https://bugs.kde.org/show_bug.cgi?id=409448


"Bonus question" would be fixing the root problem, if it's not crashing because of a bug.

After the crash, I also find: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem, like in https://bugs.archlinux.org/task/63280. However, I'm pretty certain that this is because Xorg also crashes and the "expected" environment is gone. It "starts up" normallay but then crashes after some time, usually at the same times as a mouse click.

1

Renaming the dbus service file seems to have done the trick. But I'm not sure how safe this method is in terms of updates and the interaction with KDE. But no crashes anymore.

# mv /usr/share/dbus-1/services/org.kde.kglobalaccel.service /usr/share/dbus-1/services/org.kde.kglobalaccel.service.disable
0

This seems to do it:

systemctl --user stop 'dbus\x2d:1.2\x2dorg.kde.kglobalaccel.slice'

Or 'disable' or 'mask' to make it permanently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.