2

I am running macOS 15 in a qemu virtual machine on a manjaro Linux machine. Since I want to use it for iOS development/deployment I tried connecting and forwarding an iPad running the latest iPad-OS Version. Every time I connect the iPad though the virtual machine hangs, and the only way to unfreeze it is to disconnect the iPad again. I use this command to start the VM:

#!/bin/bash

OSK="<OSK>"
VMDIR=$PWD
OVMF=$VMDIR/firmware

qemu-system-x86_64 \
    -enable-kvm \
    -m 6G \
    -machine q35,accel=kvm \
    -smp 4,cores=2 \
    -cpu Penryn,vendor=GenuineIntel,kvm=on,+sse3,+sse4.2,+aes,+xsave,+avx,+xsaveopt,+xsavec,+xgetbv1,+avx2,+bmi2,+smep,+bmi1,+fma,+movbe,+invtsc \
    -device isa-applesmc,osk="$OSK" \
    -smbios type=2 \
    -drive if=pflash,format=raw,readonly,file="$OVMF/OVMF_CODE.fd" \
    -drive if=pflash,format=raw,file="$OVMF/OVMF_VARS-1024x768.fd" \
    -vga qxl \
    -device ich9-intel-hda -device hda-output \
    -usb -device usb-kbd -device usb-mouse \
    -netdev tap,id=net0,ifname=tap0,script=no,downscript=no \
    -device e1000-82545em,netdev=net0,id=net0,mac=52:54:00:c9:18:27 \
    -device ich9-ahci,id=sata \
    -drive id=ESP,if=none,format=qcow2,file=ESP.qcow2 \
    -device ide-hd,bus=sata.2,drive=ESP \
    -drive id=InstallMedia,format=raw,if=none,file=BaseSystem.img \
    -device ide-hd,bus=sata.3,drive=InstallMedia \
    -drive id=SystemDisk,if=none,file=MyDisk.qcow2 \
    -device ide-hd,bus=sata.4,drive=SystemDisk \
    -usb -device usb-host,vendorid=0x05ac,productid=0x12ab \ # the ipad

The last arguments forward the iPad. Is there something I am missing?

Any help with this would be highly appreciated.

New contributor
Vincent Schmandt is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • One obvious thing to try is to run a Linux distro instead of MacOS in a VM with the same setup, and see if it hangs as well. If it does, it's a qemu problem (so report a bug to the qemu developers). If it doesn't, it's likely a problem in the interaction between MacOS and qemu (which again I'd report as a bug). – dirkt Nov 10 at 6:45
  • @dirkt Thanks for the hint. I tried forwarding the iPad to a Ubuntu VM and it had the exact same issue (except Ubuntu did not recover once the iPad was removed). I will report the bug and update this once I get a response. – Vincent Schmandt Nov 10 at 13:29

Your Answer

Vincent Schmandt is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.