0

I'm using Arch Linux, with bspwm. Here's a summary:

System Information

  • Operating system: Linux-5.3.8-arch1-1-x86_64-with-arch 64 Bits
  • Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version 2.80 (sub 74), branch: blender2.7, commit date: 2019-06-10 09:16, hash: rB8aa87972cac3


Here's a picture of my cursor when launching blender normally:

Without sudo

As you can see, the cursor in the bottom right corner is very difficult to see.

Here's the same thing when launching blender with sudo:

With sudo

The cursor is much more visible.

I believe the problem is with my cursor theme, captaine-cursors.

I already tried changing it to something else like Adwaita in ~/.icons/default/index.theme, but it didn't seem to do anything.

I tried using LXAppearance to change the cursor theme to the same one sudo uses (I believe it's the one in /usr/share/icons/default/index.theme), but that also didn't seem to do anything in Blender.

How can I change my cursor?


(Temporary) solution I fixed the problem by copying the crosshair from the Adwaita folder (/usr/share/icons/Adwaita/cursors/crosshair) to my local captaine-cursors folder (~/.icons/capitaine-cursors/cursors/crosshair).

So my question now is: why did blender still use the captaine-cursors crosshair when I set my cursor theme to Adwaita?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.