0

I've just installed CentOS 8 (build 1905). I use the system in English (with Hebrew as a secondary relevant language) - not in Japanese. After some initial activity (which doesn't involve playing with locales), I've somehow found myself in the following situation:

  • If I start Firefox through the desktop UI, it comes up with Japanese text on the menus and the error pages.
  • If I start Firefox from a shell (in an xterm), it starts up with English UI.

Why could this be happening and how can I fix it?

Additional information:

Contents of /etc/locale.conf:

LANG="en_US.UTF-8"

Installed Firefox package:

#  rpm -qa | grep -i firefox
firefox-68.2.0-2.el8_0.x86_64
  • What is the output of rpm -qa | grep -i firefox ? Please add said output to the question. – schaiba Nov 7 at 9:39
  • @schaiba: Done. – einpoklum - reinstate Monica Nov 7 at 9:51
  • Go to about:preferences and check the language settings, alternatives and preferred language. – schaiba Nov 7 at 9:57
  • @schaiba: Nothing is selected in the Language settings. The alternatives are [en] and [en_US] in that order. – einpoklum - reinstate Monica Nov 7 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.