0

Not sure if this is a correct place to post.

I have recently upgraded to PHP 7 on one of our webservers, however, when I do the same for another webserver, I get the below dependency error.

The steps that I am performing are as follows:

sudo yum install epel-release yum-utils
sudo yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm

sudo yum-config-manager --enable remi-php73

sudo yum install php php-common php-opcache php-mcrypt php-cli php-gd php-curl php-mysqlnd


Error: Package: php-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-xml-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libsasl2.so.3()(64bit)
Error: Package: gd-last-2.2.5-10.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5(LIBTIFF_4.0)(64bit)
Error: Package: php-mysqlnd-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: gd-last-2.2.5-10.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-json-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libwebp7-1.0.2-1.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-common-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: httpd-mmn = 20120211x8664
           Installed: httpd-2.2.15-69.el6.centos.x86_64 (@base)
               httpd-mmn = 20051115
Error: Package: php-gd-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libpng15.so.15()(64bit)
Error: Package: php-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: gd-last-2.2.5-10.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15()(64bit)
Error: Package: php-pecl-mcrypt-1.0.3-1.el7.remi.7.3.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pdo-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.2.5-10.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5()(64bit)
Error: Package: php-xml-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-opcache-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.2.5-10.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: php-cli-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libargon2.so.0()(64bit)
Error: Package: php-7.3.11-1.el7.remi.x86_64 (remi-php73)
           Requires: libargon2.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried my best to install individual dependancies but that doesn't seem to work.

Is there anyone who can please assist me with this as you may have come across similar issues.

1
  • Try yum update before installing php packages
    – Elbek
    Commented Nov 6, 2019 at 4:46

1 Answer 1

0
Error: Package: php-7.3.11-1.el7.remi.x86_64 (remi-php73)
       Requires: httpd-mmn = 20120211x8664
       Installed: httpd-2.2.15-69.el6.centos.x86_64 (@base)
           httpd-mmn = 20051115

The "Installed" package version has an el6.centos suffix. This indicates the underlying system is probably a CentOS release 6.x. The packages you are installing are from remirepo, intended for 7.x releases.

You cannot install packages intended for a RHEL/CentOS 7.x to RHEL/CentOS 6.x, because the basic system library versions are different: that's a big part of the reason why different major releases exist.

If you have already installed some "individual dependencies", the system is now likely to be an unsupportable mix of CentOS 6 and 7.

You should probably do one of these options:

  • Revert to the pre-upgrade state and re-evaluate. (This might be the easiest if you have good backups.)
  • Go through your list of installed packages and replace any installed *.el7* packages with the latest available *.el6* equivalents, or remove the *.el7* packages altogether if an equivalent does not exist/they are not needed. (Lots of manual work, but might be the best you can do to recover if you don't have a backup and cannot upgrade.)
  • Upgrade/migrate/reinstall the system to RHEL/CentOS 7.x, possibly by building up a new 7.x system or VM alongside, migrating the applications and data to it, and then tearing down the old messed-up 6.x system. (This might be the best option for the long term, as CentOS 6.x is nearing the end of its support lifecycle and you seem to need newer software than 6.x has in the first place.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .