-1

I have tried to open a pdf Using Evince Command but somehow i got this message "GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed " Help me to know more detail about this warning message

0

use Below steps to solve the problem

First I downgraded libglib2.0-0 to some earlier version using the following procedure:

In the terminal type

Code:

apt-cache showpkg libglib2.0-0

Then it shows the versions that are available in my repositories.

Then I chose the next lower version and type Code:

sudo aptitude install libglib2.0-0=version (something like 2.24.1-0ubuntu, depends on what is avaliable)

Then it downgrades ligglib2.0-0 and a bunch of other things and removed a few packages (most of them seem pretty useless)

Then I reinstalled an earlier version of evince and it didn't work. When trying to open a pdf document it said pdf type not supported. So I took a risk to upgrade evince again to the latest version (which gave me the troubles to begin with) by activating the source. libglib.2.0-0 also got upgraded and it installed a few additional packages. This time evince worked beautifully, seems a lot faster due to the upgrade.

icedtea-pluggin was removed during the downgrading and couldn't be reinstalled after the downgrading due to broken dependencies. But after the second upgrade I could reinstall it without problem.

So it all worked out in the end

4
  • Naveen Mass Thanks for sharing your knwoledge – MP Creations Nov 6 '19 at 6:21
  • you maked spelling mistake for knwoledge ,please use proper spelling .... – Veera Nov 6 '19 at 6:25
  • thanks mr. Naveen mass – MP Creations Nov 6 '19 at 6:27
  • why i want to go hell ? mr.??????? – MP Creations Nov 6 '19 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.