2

Ok, initial Deets Update: Tried wiping the Pi and retrying, I unfortunately got similar results. Any help out there?

  • Working using Putty on Windows 10
  • Connecting to a Raspberry pi 3 on my local network
  • Running Raspian Buster 9-26
  • Have DDNS Setup and working ( Things Like Nextcloud and OpenVPN are setup and working)

I tried setting up an inital SOCKs Proxy thinking it would be on a similar level of difficulty. I changed the default listening port for SSH following /default SSH port I confirmed it's listening by running

sudo netstat -antp

I got confirmation of 3 ports listening:22,80 and 8080

listen Confirmation

Next I tried to setup the tunnel to run the proxy.

ssh -D 8123 -f -C -q -N pi@example.com

I tried to verify that the process was up by trying both

ps aux | grep ssh

&

ps aux | grep PORTNUM

Where PORTNUM was a random number like 9001

I was expecting some sort of output like THIS. Where I'd see -D and the applicable port, but I never got any extra line items from that command, and the explicit port ones only showed the default result, see below.

SSH ex

port ex

I also tried running the SSHD command but it kept telling me I had an extra argument in the form of the port i wanted it to run on.

Can someone try to guide me or point me to some other resources?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.