3

I am trying to install salt-master on a new CentOS 7 server. When I run the yum install for salt-master, I get the below errors and the installation doesn't work. I seem to get the same errors if I try to install salt-ssh, salt-syndic and salt-cloud.

I used --skip-broken and it completed but I don't think it actually installed properly as I get the error salt.service could not be found if I try to start it.

Does anyone know why I get the below errors and how I can resolve them so that I can install salt master? Some of these packages I have been able to manually install but others like libssl.so.1.1()(64bit) I can't find if I do a yum search. Does anyone have a suggestion for how to install the package if I can't find it?

Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-markupsafe
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1()(64bit)
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libssl.so.1.1()(64bit)
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-pyyaml
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libssl.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-requests
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: zeromq-4.3.1-4.el8.x86_64 (salt-py3-2019.2)
           Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-six
Error: Package: salt-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-jinja2
Error: Package: salt-master-2019.2.2-1.el8.noarch (salt-py3-2019.2)
           Requires: python3-systemd
Error: Package: python3-m2crypto-0.33.0-1.el8.x86_64 (salt-py3-2019.2)
           Requires: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit)
5
  • 2
    From your posted output, it appears your are attempting to install the Python3 version of Salt-Master from the CentOS 8 repositories. Try using the CentOS 7 repositories for better results when using CentOS 7 (which still uses Python2 by default). If you want to use Python3, make sure that your CentOS 7 machine is properly setup to run Python3 first. Commented Nov 1, 2019 at 23:14
  • I ran "rpm -qf /etc/yum.repos.d/CentOS-* | sort -u" and the only ouput is "centos-release-7-7.1908.0.el7.centos.x86_64" so i think its using tge centos 7 repo? I also already have python3 installed.
    – a.smith
    Commented Nov 6, 2019 at 10:32
  • All of the packages in your output are coming from the YUM repository salt-py3-2019.2, which is not a standard repository (your test in your last comment would not find it, use yum repolist). All of the packages referenced in your question are tagged with el8 which would be for RedHat/CentOS 8. You would need to fix salt-py3-2019.2 to point to a CentOS 7 repository. Commented Nov 6, 2019 at 19:41
  • i dont understand where or why it is using el8 when i have el7 installed?
    – a.smith
    Commented Nov 13, 2019 at 15:29
  • 1
    You had to initially install the repository, unless you post the exact command you ran to configure the SaltStack repository, I can only assume that you installed the incorrect release RPM from SaltStack. The CentOS 7 Python3 SaltStack repository RPM can be found here Commented Nov 13, 2019 at 17:51

1 Answer 1

1

As GracefulRestart noted, you picked the el8 repo instead of the el7 repo when setting up Salt. Their page is not super clear, but there is an option on the page as of this writing to select "Redhat/CentoOS 7 PY3" instead of 8.

After installing the repo, you should verify that the path contains /redhat/7/ and not /redhat/8/:

$ cat /etc/yum.repos.d/salt*.repo 
[salt-py3-latest]
name=SaltStack Latest Release Channel Python 3 for RHEL/Centos $releasever
baseurl=https://repo.saltstack.com/py3/redhat/7/$basearch/latest
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/saltstack-signing-key, file:///etc/pki/rpm-gpg/centos7-signing-key

If it's not right, do the following as root or with sudo (assuming you picked the latest variety of the repo):

yum erase salt-py3-repo-latest
yum install https://repo.saltstack.com/py3/redhat/salt-py3-repo-latest.el7.noarch.rpm
yum clean all

Note that you have to run yum clean all while the repo is known to yum, so it either has to be the first or last step above. Otherwise, yum won't clean it properly and you'll still pull from the el8 repo.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .