8

I have repeatedly encountered a problem with several programs that use open/save file dialogues.

Upon initiating these by trying to open or to save a file, the program freezes for about 10 seconds and then crashes. With libreoffice for example, I get the following error message when started from terminal:

Error creating proxy: Error calling StartServiceByName for org.gtk.vfs.UDisks2VolumeMonitor: Timeout was reached (g-io-error-quark, 24)

(soffice:1466): GLib-GIO-ERROR **: 19:11:38.289: Settings schema 'org.gtk.Settings.FileChooser' does not contain a key named 'show-type-column'


Fatal exception: Signal 5
Stack:

A stack trace follows.

I have read about a similar problem on AskUbuntu.SE, but the solution (multiple versions of /usr/share/glib-2.0/schemas/org.gtk.Settings.FileChooser.gschema.xml) does not apply to me.

The file seems to have the appropriate contents (to me). Excerpt about the key mentioned in the error:

<key name='show-type-column' type='b'>
  <default>true</default>
  <summary>Show file types</summary>
  <description>
Controls whether the file chooser shows a column with file types.
  </description>
</key>

How do I fix this problem?

1
  • As a workaround, it is possible to change the desktop theme to avoid the problem. (Should I post this as an answer?) Commented Nov 1, 2019 at 16:35

4 Answers 4

5

I experienced this bug in 1.01 AppImage of Inkscape.

Mike Nealy gives an explanation and workaround in a bug report here

I've copied his workaround below:

Simply updating the schema to contain show-type-column isn't enough.

Downloading the newer schema file from https://gitlab.gnome.org/GNOME/gtk/-/blob/c925221aa804aec344bdfec148a17d23299b6c59/gtk/org.gtk.Settings.FileChooser.gschema.xml and installing it in /usr/share/glib-2.0/schemas/org.gtk.Settings.FileChooser.gschema.xml, running "glib-compile-schemas ." in that directory and using Alt-F2 r to restart gnome-shell seems to resolve the issue with Inkscape 1.0.1.

2
  • If I run inkscape from snap, it is unfortunately still crashing after doing this...
    – ha7ilm
    Commented Jun 8, 2021 at 21:01
  • 1
    gitlab.com/inkscape/inkscape/-/issues/2495 sudo snap remove inkscape && sudo snap install inkscape
    – int_ua
    Commented Jun 24, 2021 at 18:52
4

For Inkscape 1.1 from snap you have to sudo snap remove inkscape && sudo snap install inkscape https://gitlab.com/inkscape/inkscape/-/issues/2495

0

I suspect the xfce4-theme I was using is faulty as of now, so I switched to another one as a workaround. This solves my problem.

0

Removing snap and installing from apt fixed the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .