0

I am using Debian 10.1 See the following screenshot. right click and no terminal I am used to a Ubuntu environment where I do a right click and terminal opens. Is this kind of a thing possible for Debian environment. If it is possible please let me know how can I enable it?

If the same can be added to context menu like in the screenshot I see following three options
1)Change Background
2)Display Settings
3)Settings
Here can I add the option in black menu in screenshot to open terminal (I am not referring to the Ctrl+Alt+T to open terminal) some how tweaking gnome?

edit

based on discussion below package gnome-tweak-tool and nautilus-extension-gnome-terminal were installed. Then when required setting were not found as in videos here
1)https://youtu.be/scOYZZIyoM4
2) https://www.youtube.com/watch?v=scOYZZIyoM4&feature=youtu.be
gsettings get org.gnome.desktop.background show-desktop-icons
has been set to true
gsettings set org.gnome.desktop.background show-desktop-icons true

Still the desired results have not been achieved. What I want is I do a right click on any area on my desktop and in the context menu I want to see an option to open terminal.

4
  • 2
    Management of shortcuts/hotkeys is not related to your Linux flavor, but the desktop environment. As you seem to be running Gnome 3, take a look here for hotkey management.
    – FelixJN
    Commented Oct 31, 2019 at 15:11
  • 2
    Possible duplicate of How to activate the hotkeys in Linux Debian 8 Jessie (Gnome 3 DE)?
    – FelixJN
    Commented Oct 31, 2019 at 15:11
  • I want to add the option to open terminal in black menu in screenshot to open terminal (I am not referring to the Ctrl+Alt+T to open terminal) some how tweaking gnome? Commented Oct 31, 2019 at 17:08
  • 1
    Please be more specific in future. Your fist question made hotkeys sound like a valuable option.
    – FelixJN
    Commented Oct 31, 2019 at 18:01

2 Answers 2

0

Viewing your screenshot, you are using GNOME 3 (that is your DE, desktop environment, on top of Debian).
Here you can add any keyboard shortcut from GNOME's settings. You can find an useful page here [1].


[1] How to activate the hotkeys in Linux Debian 8 Jessie (Gnome 3 DE)?

0
0

For this you will have to enable desktop icons. Install Tweaks

apt install gnome-tweak-tool

And open it (called Tweaks in Activities -> Applications or via ALT+F2 gnome-tweaks). Under Desktop activate Show Icons. Right click menu now should provide Open Terminal. If not, then you will also need to install nautilus-extension-gnome-terminal.

9
  • See this screenshot drive.google.com/file/d/13EDZKv0U4sjcrD1YFrS3cbUcBiTAnp1e/… I don't see Desktop any where as you mention. Did I miss something? Commented Oct 31, 2019 at 18:28
  • Very odd. Any "show (desktop) icons"-setting somewhere? Is gnome-tweaks also installed?
    – FelixJN
    Commented Nov 4, 2019 at 12:48
  • I have made a video for you, you can see it here youtu.be/scOYZZIyoM4 I had installed both gnome-tweak-tool and nautilus-extension-gnome-terminal see the video and you will understand better what I am asking. Commented Nov 4, 2019 at 13:37
  • OK, try the following: gsettings get org.gnome.desktop.background show-desktop-icons (it should be "false") then set it to "true" via gsettings set org.gnome.desktop.background show-desktop-icons true. You should now have the content of your home-dir on the desktop AND right-click should allow opening a terminal.
    – FelixJN
    Commented Nov 4, 2019 at 13:45
  • it did not worked commands I tried here is another video youtu.be/YrLw7ckA3Pk Commented Nov 4, 2019 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .