I have a local user issue which I don't know how to solve: all users can log without any problem, except one user who is each time kicked back to gdm screen though password authehtication succeeds (no password error message). 'su - {user}' works fine, so not a pwd issue. I tried to remove ~{user}/.ICEauthority and all /tmp files|dirs belonging to this user, but still doesn't work.

I guess there is kind of trivial solution, but can't figure out what it is. :-(

I'm in Fedora 30 under Wayland, more than happy to provide more information if needed.

A bit more details/context:

last shows that indeed the user actually connected on a tty
`watch -n 0.1 'who -a'` doesn't show the user, even a single time So it seems that login succeeds, a tty is attributed, but it never goes to the who command input source. Could this help? Thanks!

Any idea?
Thanks a lot

Answering to myself, finally succeeded in sorting this out.
Was right, wasn't a system issue but a local one.
In despair, I listed all files/dir in faulty user home which had been modified within a short time range before issue appeared, and finally removed following dirs in ~user/.local/share:

  • gnome-shell
  • gvfs-metadata
  • keyrings

Then tried to log with the user, and guess what, worked like a charm! So it was related to one (or all) of these directories. I would suspect .gnome-shell, but no evidence of it.
If now someone wants to try to clarify my answer explaining what may have happened, I would be more than happy and would help the community.
Also I changed the topic to make it more relevant.

  • Please, post journal errors/info. At first glance could be a Wayland compatibility issue: did you try to login with X?
    – mattia.b89
    Oct 30, 2019 at 11:25
  • I can do it. Which extract do you want? What would be hard to understand with Wayland compatibility is that we are 7 users on the computer, and since few days ago all users could log in without any problem; now only one user cannot log in, all others can log in working like a charm. Oct 30, 2019 at 11:29
  • you can post full journalctl log
    – mattia.b89
    Oct 30, 2019 at 11:31
  • full journalctl is 400Mo; is it ok? :-) Oct 30, 2019 at 11:39
  • hmm may look like silly question, but how do I attach a file to this question? :"> Should I post entries inline? Oct 30, 2019 at 11:47

2 Answers 2


No idea anybody? I'm convinced there is something in the user homedir which makes the X login fail and have the tty login work. Not related to .ICEauthority, as removing it doesn't solve the issue. If someone has an idea, please do!


Afer reading this question, I went on deleting massacre of anything related to gtk or gnome in .config and .local/share

I had already deleted gnome-shell, gvfs-metadata, keyrings but I was still not able to login. Finally I uninstalled gdm and then deleted /var/lib/gdm/ and reinstalled gdm it worked. I'm still not sure if deleting /var/lib/gdm/ did the trick cause I deleted lots of files on .config and .local/share

Also I was able to login via Wayland session of Gnome and Plasma but not Xorg. SDDM was also working fine with both Xorg and Wayland but I didn't liked it because it was running as root

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .