2

I have a trouble connecting a raspberry pi from my work. My rasp is at home, ssh listening on port 22 but I can only use the port 443 to go outside from my work network. So, my home internet box forwards the 443 to the 22. This has worked for months.

But now, I can't ssh anymore (user and IP are changed):

# ssh -vvv -p 443 myuser@10.0.0.1
OpenSSH_7.1p2, OpenSSL 1.0.1g 7 Apr 2014
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 10.0.0.1 [10.0.0.1] port 443.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/me/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.9p1 Raspbian-10+deb10u1
debug1: match: OpenSSH_7.9p1 Raspbian-10+deb10u1 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 10.0.0.1:443 as 'myuser'
debug1: SSH2_MSG_KEXINIT sent
Connection reset by 10.0.0.1

When I'm at home (local network), I can ssh without any trouble.

I updated (and rebooted) my rasp on sunday, but ssh worked from my working place monday morning. We had small modifications on our network on monday noon, but nothing about the ports.

Any idea ?

  • 1
    10.0.0.1 is a local address, you should not be able to connect to your home network from work on that address unless it is somehow proxied or forwarded, or if it is a VPN which your home machine is part of too. – Kusalananda Oct 30 '19 at 8:08
  • 10.0.0.1 is an example, I use my real public IP for my tests. – Locaol Oct 30 '19 at 8:20
  • traffic on port 443 can be inspected by firewall, and rejected if not a proper https dialog. – Archemar Oct 30 '19 at 8:26
  • @Archemar: yes, I was blocked by a "Non-SSL Traffic over SSL Port" rule. I disable the blocking and now it works :) – Locaol Oct 30 '19 at 9:49
  • I let you edit title with Cannot SSH on https (443) from external network – Archemar Oct 30 '19 at 10:05
2

Btw, I found a ssh web console (https://www.serfish.com/console/) and tested: everything is ok on my rasp, so the trouble is in my work network. Looks like our new firewall configuration (sonicwall NS2650) has a trouble with my ssh :(

This question can be closed, I'll look in the firewall settings and help :)

  • It's probably doing packet/traffic inspection to stop exactly the sort of thing you're doing. – roaima Oct 30 '19 at 8:53
  • Yes, I was blocked by a "Non-SSL Traffic over SSL Port" rule. I disable the blocking and now it works :) – Locaol Oct 30 '19 at 8:59
  • 1
    Just a piece of advice: now you used a "web console", change your password. A friend of mine got compromised by typing his password on that kind of "free service"... – binarym Oct 30 '19 at 9:34
  • @binarym I need a 😮 icon for that. Amongst others – roaima Oct 30 '19 at 9:40
  • 1
    @roaima : yes, I can, in 2 days :) – Locaol Oct 30 '19 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.