1

I dual-booted Windows 10 with Manjaro and installed the GRUB bootloader in /dev/sda but no bootloader loads when system starts and it directly goes into Manjaro. I have to press F12 every time to go into Windows. How to fix it?

  • Well, there is a bootloader otherwise your system will not boot up. However, the GRUB menu is disabled. This is a broad question, Google it and you will find a solution. – Prvt_Yadav Oct 30 '19 at 0:31
  • 1
    google grub how to add windows – jsotola Oct 30 '19 at 3:52
0

First, don’t forget to backup.

Now the second thing I’d recommend, maybe just try:

sudo update-grub

I read about this issue on a manjaro forum so might work. Maybe after the grub install, this command was not used?

To make sure that works, or after it doesn't, the settings you are looking for are in /etc/default/grub Use your favorite editor, vi or whatever to change the variable GRUB_HIDDEN_TIMEOUT=0 to something other than zero seconds or use # to comment it out completely.

Now, make sure grub’s up to date: sudo update-grub


Also, I always like to provide ppl with exiting vi strategies so just fyi: Hit the Esc key to enter "Normal mode". Then you can type : to enter "Command-line mode".

  • :q! to quit without saving (short for :quit!)
  • :wq to write and quit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.