0

When I try to run man -k ., I only get a list of commands starting with pvck. So when I run man ls for example, I get a blank page that asks me to select h for help or q to quit. The same thing happens when I run man sudo and man apt. Alternatively, if I run man --help or ls --help then I will get the correct output there.

I am using KDE Neon (Ubuntu 18.04). Let me know if you need any other information. Thanks.

4
  • Are you sure it is a KDE problem? Did you try in a TTY just to check that out? What says type man (should be /usr/bin/man)
    – xenoid
    Commented Oct 29, 2019 at 20:12
  • Mine does show /usr/bin/man when I run type man. Yes, in a TTY I see the same thing for the man pages.
    – OkieKing
    Commented Oct 29, 2019 at 20:25
  • So likely unrelated to KDE, Neon and Konsole, I suggest removing these tags. Your distro and release may be more pertinent.
    – xenoid
    Commented Oct 29, 2019 at 20:45
  • Got it, I've update the original post. It's on Ubuntu 18.04.
    – OkieKing
    Commented Oct 29, 2019 at 21:15

1 Answer 1

0

OK, I've found the answer on https://forum.pine64.org/showthread.php?tid=6787&highlight=manpages. It looks like we need to install something called apparmor to fix this. The code I ran was sudo apt install apparmor-utils && sudo aa-disable /usr/bin/man.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .