2

Ahoy friends. Currently i'm trying to get Parted Magic running on my PXE server providing NFS support. So i had to edit the initrd.img file, had to add the scripts, and everything worked well. But unfortunately i forgot the USB support. So i wanted to unpack the file again (1 week later) and after adding i tried to pack it again and get it running. Unfortunately it doesn't work anymore, but i don't know why. Did i forget any steps? Unfortunately it's 1 week ago and i used this tutorial in here. https://access.redhat.com/solutions/24029

So what did i do? I took the working image which is still working right now, unpacked it, repacked it without any changes ---> and it's not working anymore. My steps well explained:

Uncompressed the image after changing into a workdir.

xz -dc < ../initrd.img | cpio -idmv

Compressed the image again.

find . 2>/dev/null | cpio -c -o | xz -9 --format=lzma > ../initrd.img

Finally it's not working anymore.

During the boot i got this error.

enter image description here

Same initrd.img (before performing the steps above) Running fine.

enter image description here

What's the problem, and are there any tools to generate initrd files to let them run on other systems? I use Debian.

0

Ahoy. Just found out why it didn't work well. The size of the working initrd.img is 125MB. The max allowed size for an initrd.img file 128MB. After extracting it and recompressing it it's file size is 143MB, so it doesn't boot anymore. Because of this im look for another compression algorithm only!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.