1

I keep running into weird permissions issues on a server called nucserv...

exharris@nucserv:~/Downloads$ cat /etc/issue
Ubuntu 18.04.3 LTS \n \l

Today..plex media server told me it was due an update, not essential, so I downloaded it and just tried to run :0

exharris@nucserv:~/Downloads$ sudo apt install plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb

It asked for me for a password and then said

[sudo] password for exharris:  Reading package lists... Done Building dependency tree        Reading state information... Done E: Unable to locate package plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb E: Couldn't find any package by glob 'plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb' E: Couldn't find any package by regex 'plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb'

I think it may be permissions. la-all | grep plex says

exharris@nucserv:~/Downloads$ ls -all | grep plex
-rw-rw-r--  1 exharris exharris   75202898 Oct 19 14:23 plexmediaserver_1.18.0.1944-f2cae8d6b_amd64.deb
-rw-rw-r--  1 exharris exharris   86884196 Oct 28 15:30 plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb

(v1944 is an old plex update one I also failed to install... , I don't believe one has to install them have to install them all in order, but might be wrong.)

Kubuntu Software Centre says it is not due an update?

I downloaded these .debs from Chromium whilst logged onto the server via Google Chrome Remote Desktop. Unsure if relevant.

  • Have you tried sudo apt install ./plexmediaserver_1.18.1.1973-0f4abfbcc_amd64.deb? i.e. Making sure to designate that the package is local to your filesystem so apt does not try to query the remote repositories. – GracefulRestart Oct 28 '19 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.