-2

I just bought a new HP laptop just for the purpose of installing and learning Kali linux. It had originally windows 10 installed in it. I downloaded and installed the latest version of kali linux. Everything seems to be good and working but when I tried to connect to internet, I can't to it. I can just connect using wired connection. For wireless connection, it says no wifi adapter found. I did not install kali on any virtual machine, my pc is a pure kali linux now straight booted in the drive.

When I type iwconfig in the terminal, it just shows me eth0 and lo. It doesn't show wlan0. I tried looking for solution for a whole day now. I tried a method, "download compact wireless" that everyone was showing, I was able to get wlan0 and wlan1, but now the problem is it doesn't detect any wifi. Also when I reboot my laptop, it is gone and I have to do it again, its not saved.

I have also realised that bluetooth is also not working. However, the download compact wireless method seems to fix the bluetooth, but ita gone at restart. There are people who said I need to get an adapter, but the laptop should have build in wifi card right? And I directly booted up in the machine, not in any virtual box, so do I really need to buy one? Whats the point of me buying a new laptop just for Kali? Please help me.

  • Add some detail of the HP laptop model ? – steve Oct 27 '19 at 20:14
  • There is little point buying a laptop to learn Kali. It's usually run as a virtual machine. – roaima Oct 27 '19 at 21:04
0

It is very unlikely that your HP laptop has a Kali Linux supported WIFI adapter.

Here is a list of some chipsets supported by Kali Linux

  • Atheros AR9271
  • Ralink RT3070
  • Ralink RT3572
  • Realtek 8187L (Wireless G adapters)
  • Realtek RTL8812AU (newly in 2017)

You can find more details in this article

https://null-byte.wonderhowto.com/how-to/buy-best-wireless-network-adapter-for-wi-fi-hacking-2019-0178550/

| improve this answer | |
0

Kali doesn't ship with proprietary wifi drivers, I've found someone with the same problem here, try following some of these steps.

You could try

apt-get install firmware-iwlwifi

modprobe -r iwlwifi; modprobe iwlwifi

| improve this answer | |
0

Nearly all of hp laptops have this issue , it's the wifi adapter which only has one antenna and so you need to install a different firmware. I have to do it again and again so I made a script. Plug an Ethernet connection using USB tethering and

make a file fixwifi.sh using

nano fixwifi.sh

Copy the contents

apt install linux-headers-$(uname -r) git build-essential dkms
git clone git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo modprobe -r rtl8723de && sudo modprobe rtl8723de
echo "options rtl8723de ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723de.conf

Save the file with

Ctrl+s and Ctrl+x

Execute it using

chmod +x fixwifi.sh && ./fixwifi.sh

and you are good to go.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.