3

I added a new user to my server and the .ovpn file seems to have so missing things which I can't understand. I have the same config with other keys and the same parameters for another machine and it works fine there. Here are the parameters.

client
dev tun
proto udp
remote 207.180.225.35 1194
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
auth SHA512
cipher AES-256-CBC
ignore-unknown-option block-outside-dns
block-outside-dns
tls-crypt
verb 3
<ca>
-----BEGIN CERTIFICATE-----
#******************************************************************************************
(obfuscated)
#******************************************************************************************

-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
#******************************************************************************************
    (obfuscated)
#******************************************************************************************
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
#******************************************************************************************
(obfuscated)
#******************************************************************************************
-----END PRIVATE KEY-----
</key>
<tls-crypt>
-----BEGIN OpenVPN Static key V1-----
#*********************************************
(obfuscated)
#*********************************************
-----END OpenVPN Static key V1-----
</tls-crypt>

The error message is:

Sun Oct 27 16:37:34 2019 Unrecognized option or missing parameter(s) in /home/vpnOrdner/upper.ovpn:13: block-outside-dns (2.3.9)
Options error: Unrecognized option or missing parameter(s) in /home/vpnOrdner/upper.ovpn:18: tls-crypt (2.3.9)
Use --help for more information.

The client machine runs Debian (openPli) and the server runs on Debian 10.

I tried deleting the line with "block-outside-dns" but it didn't fix the error with tls-crypt.

1
  • Have you tried to delete or comment the line with tls-crypt, because you have already the tls-crypt cert at the end. Oct 27, 2019 at 19:22

1 Answer 1

4

It seems you're using OpenVPN 2.3.9.

Options such as block-outside-dns and tls-crypt are available only in the OpenVPN 2.4.x.

You can upgrade your OpenVPN and use the same .ovpn file.

1
  • Yes, thank you. It worked after I removed openvpn 2.3, downloaded the openvpn 2.4 (.deb package) and installed it May 11, 2020 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.