2

Cygwin inserts a space everywhere after a combination of letters "fi". It is only visually so, if you copy the text, this space disappears.

enter image description here

And here's the text I copied:

#
pidfile = /var/run/fail2ban/fail2ban.pid

# Options: dbfile
# Notes.: Set the file for the fail2ban persistent data to be stored.
#         A value of ":memory:" means database is only stored in memory
#         and data is lost when fail2ban is stopped.
#         A value of "None" disables the database.
# Values: [ None :memory: FILE ] Default: /var/lib/fail2ban/fail2ban.sqlite3
dbfile = /var/lib/fail2ban/fail2ban.sqlite3
6
  • 5
    Did you install/enable a font with ligatures (such as FiraCode)? Oct 27 '19 at 11:46
  • What editor did you type or paste this into? It appear to automatically insert ligatures.
    – Kusalananda
    Oct 27 '19 at 13:07
  • I've Menlo for Powerline, 10pt
    – khashashin
    Oct 27 '19 at 14:59
  • What terminal are you using? This doesn't involve zsh. Oct 27 '19 at 20:10
  • 1
    Looks like some versions of "Menlo for Powerline" have ligatures. Try one of the versions that doesn't, instead. Or some other truly monospaced font.
    – roaima
    Oct 27 '19 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.