2

I am attempting to install Linux Mint 19.2 onto a MacBook Pro from 2011. There is currently no operating system on the MacBook only the boot from the live USB, as when I first attempted to install Mint, I wiped the existing operating system (which was nonfunctional anyway, because the system would hang in a reboot loop before you could even attempt to login, so this doesn't really change anything).

This laptop is from 2011, so there's no T2 security chip for me to disable and no secure boot option for me to disable.

My boot medium is a USB stick that uses the GPT partitioning scheme for UEFI systems. I (also tried using one for BIOS, but it runs into the same, following issue) and I select it from the UEFI menu. I am then taken to the GRUB menu, where I highlight "Start Linux Mint" and edit the commands to add noefi and nomodeset after quiet splash in order to fix the database and size errors I usually encounter, which look something like this:

Couldn't get size: (some hex number) MODSIGN: Couldn't get UEFI db list Couldn't get size: (some hex number)

Once I have live booted Mint, I attempt to install it. I choose to erase everything from the disk and install.

It notifies me that the following partitions will be changed

SCSI1 (0,0,0) (sda)

and the following partitions are going to be formatted

partition #1 of SCSI1 (0,0,0) sda as ESP

partition #2 of SCSI1 (0,0,0) sda as ext4

It works, right up until it has to install GRUB, at which point I get the message 'Executing 'grub-install /dev/sda/' failed. This is a fatal error.'

I've seen people suggest installing rEFInd instead of using GRUB, but how can I install it when I don't have an (installed) operating system on this MacBook? Failing that, how can I get around this issue?

0

Okay, here's what I did.

  1. Booted from the GRUB menu, pressed e, replaced quiet splash with nomodeset instead of putting it next to it.

  2. Booted successfully. When I went to install, I had a previous install on there, and instead of wiping it, I resized the partitions so they got half the hard disk size each.

  3. For some reason, once I had done this, Mint did grub-install /dev/sda successfully. (Could be because I kept the previous Mint install, could also be because I replaced quiet splash with nomodeset, but I don't think the latter is it).

  4. I rebooted, removed the boot USB when prompted.

  5. Rebooting just sent me back to another blank screen, so I forced shut down, booted again, went in the advanced boot options, changed the kernel to 4.15, pressed e to edit the advanced boot commands to replace quiet splash with nomodeset.

  6. Mint loads successfully. Then, from the terminal I wrote sudo nano /etc/default/grub and wrote nomodeset setting next to where quiet splash was.

Again, I'm not really sure which step fixed my grub-install issue, but these added steps did fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.