1

I run a dual-boot Win 10/Linux Mint 19 system on a desktop with a more than adequate processor and plenty of RAM and HDD. I have both Thunderbird and Firefox running in both systems, each sharing a common profile located on an internal Windows data drive.

I continually get the above error in both Thunderbird and Firefox, but only in Linux.I have tried:

1). Using "system monitor" to discover the running process. None appears.

2). Using command line "pidof thunderbird (or firefox)" to discover the process. None shows.

3). Using command lines "pkill" or "killall" in their various forms, with no result other than "no such process".

4). After closing the programme, going to the profile folder and deleting the "lock" or ".parentlock" file before shutting down the computer. This is often successful, but not always.

5). Opening Windows first, going to the profile folder and deleting the ".parentlock", "parent.lock" and "lock" folders when found, then restarting in Linux.

This has had the greatest rate of success until this morning, when I started the computer in Linux after it had been shut down all night, got the error message, found no running processes, either in System Monitor or "pidof" and found no lock files in the profile folder - i.e. there was no running process!!

I restarted in Win, went to the profile folder, and found no ".parentlock", "parent.lock" or "lock" folders. Both Thunderbird and Firefox worked normally in Windows.

6). Restarting the system - this has never worked. Generally speaking, neither Firefox nor Thunderbird remove the ".parentlock" file when I shut them down, even if I give them ten minutes to do so, and I have to remove the files manually before shutdown. Doing so usually works, though not always! The problem has only been apparent for some three months or so, and seemed to appear after one of those dreaded Win 10 updates. Updates to Firefox and Thunderbird might also be involved, as I always have the latest versions installed.

Usually, if, when I first switch on the computer, I check for ".parentlock" in the appropriate profile folder and remove it when present, I can start Firefox and Thunderbird normally, but this was not the case this morning - the ".parentlock" files were absent, but Thunderbird still reckoned it was running.

How is this all poossible, and how can I fix it???

  • What filesystem is that "internal Windows data drive" the common profile is located on? how is it mounted in Linux? – mosvy Oct 26 '19 at 23:47
0

Jeff, I replied a couple of days ago, but was not registered and having trouble doing so, thus my response seems to have disappeared - sorry! The profile is located in my Windows Data partition (E:) on the 2TB HDD, where Windows (C:) is also located. Linux is installed on a separate HDD. I have set up T'bird and FF in Linux to refer to this profile location, as do the programmes in Windows, so they are kept synchronised in both O/S's. The file system used is thus NTFS, accessible in Linux, and this setup has worked perfectly well until recent updates (shortly after a Win 10 update), and now I have this trouble. Process 5). above seems to have the greatest success rate, but it is still a bit of a pain to have to boot into Win 10, delete any "lock", "parent.lock" and ".parentlock" files before re-booting into Linux in order to get T'bird and FF to work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.