1

I have a Dell G5 laptop with Windows 10 and Ubuntu 16.04 installed to an NVME drive with /home and D: partitions mounted on the Hdd

Previously, when I switched my laptop on it would go to GRUB by default and I could choose which OS I wanted to boot. I have just booted into Windows and ran the Dell Firmware update tool and found that this has altered my booting priority and now Windows will boot automatically.

My efi boot priority is:

$ sudo efibootmgr 
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,0001,0000
Boot0000* Windows Boot Manager
Boot0001* ubuntu
Boot0002* UEFI: KBG30ZMS128G NVMe TOSHIBA 128GB, Partition 1

$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop1         7:1    0    89M  1 loop /snap/core/7713
nvme0n1     259:0    0 119.2G  0 disk 
├─nvme0n1p7 259:7    0  48.8G  0 part /
├─nvme0n1p5 259:5    0  12.7G  0 part 
├─nvme0n1p3 259:3    0  54.9G  0 part 
├─nvme0n1p1 259:1    0   650M  0 part /boot/efi
├─nvme0n1p6 259:6    0   1.1G  0 part 
├─nvme0n1p4 259:4    0   990M  0 part 
└─nvme0n1p2 259:2    0   128M  0 part 
loop4         7:4    0 172.5M  1 loop /snap/skype/92
loop2         7:2    0 159.8M  1 loop /snap/vott/x1
loop0         7:0    0  89.1M  1 loop /snap/core/7917
sda           8:0    0 931.5G  0 disk 
├─sda4        8:4    0 907.2G  0 part /home
├─sda2        8:2    0   9.3G  0 part 
├─sda3        8:3    0  14.9G  0 part [SWAP]
└─sda1        8:1    0   128M  0 part 
loop3         7:3    0 172.6M  1 loop /snap/skype/96

$ sudo update-grub
[sudo] password for luke: 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-66-generic
Found initrd image: /boot/initrd.img-4.15.0-66-generic
Found linux image: /boot/vmlinuz-4.15.0-65-generic
Found initrd image: /boot/initrd.img-4.15.0-65-generic
Found linux image: /boot/vmlinuz-4.4.0-166-generic
Found initrd image: /boot/initrd.img-4.4.0-166-generic
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done

If I bring up the boot menu after POST and manually select the second "ubuntu" entry, GRUB boots as expected. So I tried going into the UEFI and promoting "ubuntu" to the first default boot option - the result is that the computer launches into some kind of Dell rescue utility and won't load either system - informing me that booting is corrupted. Returning the boot order back to the above allows me to boot either Windows or GRUB.

How can I boot into GRUB by default?

1

Simply running update-grub (and then setting "ubuntu" as the first UEFI boot priority) resolved the issue.

| improve this answer | |
  • Just in case, you might be interested in knowing about the excellent Rod's books on the topic: rodsbooks.com/efi-bootloaders -- these helped me a lot back when implementing UEFI support in ALT Linux... – Michael Shigorin Oct 26 '19 at 14:39
  • thanks, good to know for the future. – ezekiel Oct 28 '19 at 15:15
0

efibootmgr -o 0001 This command will set your first boot option to ubuntu.

| improve this answer | |
  • the problem was that setting the first boot option to Ubuntu caused nothing to be bootable. So I tried going into the UEFI and promoting "ubuntu" to the first default boot option - the result is that the computer launches into some kind of Dell rescue utility and won't load either system - informing me that booting is corrupted. – ezekiel Oct 25 '19 at 11:44
  • Well, have you tried to disable secure boot? – rpirea Oct 25 '19 at 11:46
  • yes, see my answer, simply running update-grub (and then setting "ubuntu" as the first UEFI boot priority) resolved the issue. – ezekiel Oct 25 '19 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.