0

I have created this file /proc/sys/net/ipv4/icmp_echo_ignore_all couple of months ago on my centos 7 server to disable ping requests permanently and now I can not undo this!

I'm logged in as root user but still can not use command rm /proc/sys/net/ipv4/icmp_echo_ignore_all to remove this file! I even checked immutable bit and its not set on that file... I get the same error:

rm: cannot remove ‘/proc/sys/net/ipv4/icmp_echo_ignore_all’: Permission denied

But magically i can edit file with nano without errors but editing not cause any chances to enable icmp ping requests again! I think it must be removed but seems to be impossible!

can anyone help??

1 Answer 1

0

You can’t delete that file. To re-enable ICMP echoes you need to write 0 to it; as root:

echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all
2
  • I have done this before and one time again now but it not worked in my case and still server is not replying to any ping requests. Oct 23, 2019 at 22:44
  • That suggests that you’ve disable other ICMP settings, or maybe that pings are blocked by your firewall... Oct 24, 2019 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .