I use this setting, but still see cursor before launch plymouth in debian 10

RUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=0 splash"

You could try adding the kernel parameter


to the GRUB parameter line (see, e.g. the Kernel Admin Guide or this article).

  • It is not work, i see cursor after grub menu and before plymouth – Sergey Shamanayev Oct 23 '19 at 9:39
  • Hm, that is strange. Unfortunately, I do not know of any other way so far .. – AdminBee Oct 23 '19 at 10:50
  • Ok, no important for now. Need to do make bug report to GRUB2? – Sergey Shamanayev Oct 23 '19 at 14:06
  • I don't think this would be a case for a GRUB bug report because the parameters from GRUB_CMDLINE_LINUX_DEFAULT are passed to the linux kernel. As long as we have no reason to suspect that the parameter is "lost" before being passed to the linux kernel (try looking in journalctl -b for hints that the parameter is set correctly), that would rather be a case for a bug report to the Linux kernel developers (but that should be done with caution and after extensive checking that the problem is not on the user side ...). – AdminBee Oct 23 '19 at 14:57
  • 1
    Just an FYI, but this also works for Raspberry Pi if you append this to the /boot/cmdline.txt – CenterOrbit Dec 18 '20 at 19:06
  1. Add to grub config /etc/default/grub kernel parameter

A) Use in real hardware


B) Use in VirtualBox

  1. Uncomment


  2. Add the line


  3. Update changes


I found it when investigate parameter vga=current on Silent boot parameter which deprecated

  • P.S. black background in corner still exist. Welcome new solution to fix it – Sergey Shamanayev Oct 24 '19 at 9:45
  • Usage vt.cur_default=50 fix for me black background. See manual for this parameter to undertake why – Sergey Shamanayev Oct 26 '19 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.