3

I do debian minimal installation (no desktop on install), then add openbox, lightdm

apt-get install xorg openbox lightdm plymouth plymouth-themes

Also i hide grub menu and boot log messages. For it i do changes in /etc/default/grub

GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=0"

And (optional) use plymouth for show nice welcome image, but is still see login tty for less then second.

enter image description here

How to hide it forever?

Next image it is graphic login screen and it is ok for me, i know how to do auto login to hide it (same as described bellow)

enter image description here

P.S. When i install debian by default with desktop it load without login console, i just add "splash to grub settings".

7
  • Just to confirm, are you booting into a graphical environment or only a tty? Is this screen flashing before it then moves to a lightdm screen? Or is this the only login screen you need to get rid of?
    – kemotep
    Oct 22, 2019 at 15:25
  • I booting into a graphical environment lightdm. Yes i see flash for tty for less 1 second before graphic login form screen. Oct 22, 2019 at 15:46
  • Can you reinstall lightdm and try the settings in my answer? apt-get --purge remove lightdm then apt-get install lightdm Verify that the lightdm service is enabled and add your user to the autologin group groupadd -r autologin usermod -a user autologin After than make sure that your configurations match what is in my post and comment back if those work or not.
    – kemotep
    Oct 22, 2019 at 16:06
  • I remove/add lightdm, add group, add user in group, made lightdm autologin for my user, but still see flash tty login Oct 23, 2019 at 4:56
  • But i use this command usermod -aG usergroup username Oct 23, 2019 at 5:03

1 Answer 1

1

Now i find small solution here bbs.archlinux.org/viewtopic.php?id=201321 I rename/remove/delete file in folder /etc/systemd/system/getty.target.wants/

Not sure it is correct answer, but it work. Blinking cursor will stay, but it better then before

1
  • Add "vt.global_cursor_default=0" in /boot/cmdline.txt to get rid of the blinking cursor. (Tried it on RPI4)
    – Omid N
    May 28 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.