8

I just got a new display (Samsung LC27JG50QQU, 1440p, 144hz) which is plugged into my AMD Radeon HD 6950 (DVI-D, DVI-I, HDMI 1.4, 2x Mini DisplayPort) graphics card using HDMI. However, it only lets me set 1080p max in my display settings. Cable and monitor were fine on 1440p with my MacBook Pro.

I am running Linux Mint 19.1 Tessa

This is the output xrandr gives:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-3 disconnected (normal left inverted right x axis y axis)
DisplayPort-4 disconnected (normal left inverted right x axis y axis)
HDMI-3 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1080     60.00*   50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DVI-0 disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)
VGA-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 disconnected (normal left inverted right x axis y axis)
HDMI-1-3 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)
DP-1-3 disconnected (normal left inverted right x axis y axis)

lspci -k | grep -EA3 'VGA|3D|Display':

00:02.0 Display controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    Subsystem: Gigabyte Technology Co., Ltd 2nd Generation Core Processor Family Integrated Graphics Controller
    Kernel driver in use: i915
    Kernel modules: i915
--
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cayman PRO [Radeon HD 6950]
    Subsystem: Hightech Information System Ltd. Cayman PRO [Radeon HD 6950]
    Kernel driver in use: radeon
    Kernel modules: radeon

glxinfo | grep -i vendor:

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: X.Org (0x1002)
OpenGL vendor string: X.Org

EDID:

00ffffffffffff004c2d560f4d325530
071d0103803c22782a1375a757529b25
105054bfef80b300810081c081809500
a9c0714f0101565e00a0a0a029503020
350055502100001a000000fd00324b1b
5919000a202020202020000000fc0043
32374a4735780a2020202020000000ff
0048544f4d3230303034340a2020014d
02031bf146901f041303122309070783
01000067030c0010008032023a801871

6 Answers 6

13

First create the appropriate modeline with cvt

$ cvt 2560 1440 
# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

Then add the mode using xrandr --newmode

$ xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

Finally set your display to that particular mode:

$ xrandr --addmode HDMI-3 2560x1440_60.00
$ xrandr --output HDMI-3 --mode 2560x1440_60.00

EDIT 1:

Going by the OP's EDID his monitor is reported as **C27JG5x ** . edid-decode also reports the following:

EDID version: 1.3
Manufacturer: SAM Model f56 Serial Number 810889805
Made in week 7 of 2019
Digital display
Maximum image size: 60 cm x 34 cm
Gamma: 2.20
DPMS levels: Off
RGB color display
First detailed timing is preferred timing
Display x,y Chromaticity:
  Red:   0.6523, 0.3408
  Green: 0.3203, 0.6083
  Blue:  0.1455, 0.0654
  White: 0.3134, 0.3291
Established timings supported:
  720x400@70Hz 9:5 HorFreq: 31469 Hz Clock: 28.320 MHz
  640x480@60Hz 4:3 HorFreq: 31469 Hz Clock: 25.175 MHz
  640x480@67Hz 4:3 HorFreq: 35000 Hz Clock: 30.240 MHz
  640x480@72Hz 4:3 HorFreq: 37900 Hz Clock: 31.500 MHz
  640x480@75Hz 4:3 HorFreq: 37500 Hz Clock: 31.500 MHz
  800x600@56Hz 4:3 HorFreq: 35200 Hz Clock: 36.000 MHz
  800x600@60Hz 4:3 HorFreq: 37900 Hz Clock: 40.000 MHz
  800x600@72Hz 4:3 HorFreq: 48100 Hz Clock: 50.000 MHz
  800x600@75Hz 4:3 HorFreq: 46900 Hz Clock: 49.500 MHz
  832x624@75Hz 4:3 HorFreq: 49726 Hz Clock: 57.284 MHz
  1024x768@60Hz 4:3 HorFreq: 48400 Hz Clock: 65.000 MHz
  1024x768@70Hz 4:3 HorFreq: 56500 Hz Clock: 75.000 MHz
  1024x768@75Hz 4:3 HorFreq: 60000 Hz Clock: 78.750 MHz
  1280x1024@75Hz 5:4 HorFreq: 80000 Hz Clock: 135.000 MHz
  1152x870@75Hz 192:145 HorFreq: 67500 Hz Clock: 108.000 MHz
Standard timings supported:
  1680x1050@60Hz 16:10 HorFreq: 64700 Hz Clock: 119.000 MHz
  1280x800@60Hz 16:10
  1280x720@60Hz 16:9
  1280x1024@60Hz 5:4 HorFreq: 64000 Hz Clock: 108.000 MHz
  1440x900@60Hz 16:10 HorFreq: 55500 Hz Clock: 88.750 MHz
  1600x900@60Hz 16:9
  1152x864@75Hz 4:3 HorFreq: 67500 Hz Clock: 108.000 MHz
Detailed mode: Clock 241.500 MHz, 597 mm x 336 mm
               2560 2608 2640 2720 hborder 0
               1440 1443 1448 1481 vborder 0
               +hsync -vsync 
               VertFreq: 59 Hz, HorFreq: 88786 Hz
Monitor ranges (GTF): 50-75Hz V, 27-89kHz H, max dotclock 250MHz
Monitor name: C27JG5x
Serial number: HTOM200044
Has 1 extension blocks
Checksum: 0x4d (valid)

While this error might just as likely radeon (namely drmmode_do_crtc_dpms cannot get last vblank counter reported in Xorg.log) driver ( a fix I am in the process of putting together in EDIT 2), in OP's case the monitor might be able to produce an output with the following modeline as reported by edid-decode:

Modeline "2560x1440"  241.500  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync

and then again using xrandr as follows:

$ xrandr --newmode "2560x1440"  241.500   2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
$ xrandr --addmode HDMI-3 "2560x1440"
$ xrandr --output HDMI-3 --mode 2560x1440

This might very well work as both cvt and gtf fails in producing a modeline limited by the EDID reported max dotclock of 250MHz. My own monitor (only capable of 1080p) actually tries to produce the impossible the 2560x1440 resolution when given a modeline properly limited by the EDID max dotclock, unlike when given the cvt modeline which completely shuts down the monitor into standby mode with a message on the screen that says "input not available".

In OP's case it was necessary to further drop the refresh rate through limiting the dotclock so the following two modelines may need to be used instead of the one above.

xrandr --newmode "2560x1440_54.97" 221.00 2560 2608 2640 2720 1440 1443 1447 1478 +HSync -VSync 
xrandr --newmode "2560x1440_49.95" 200.25 2560 2608 2640 2720 1440 1443 1447 1474 +HSync -VSync

One additional important point is to make sure that the GPU clock as specified by the driver is also capable of the chosen bandwidth by checking the value reported by:

grep -iH PixClock /var/log/Xorg.*

, and even more importantly that the cable standard you are using conforms to the following limits:

enter image description here

19
  • I followed those steps, but here's what happens: - In the OS it changes the resolution to 2560x1440 - The display displays those pixels at 1281x1431 - Everything looks mushed together and unreadable.
    – Bart
    Commented Oct 21, 2019 at 7:38
  • And now it just doesn't recognize those outputs and the monitor keeps searching for a video output with the screen black.
    – Bart
    Commented Oct 21, 2019 at 8:12
  • If you sure your GPU can actually display that resolution through the HDMI port. then the only other possibility is outdated drivers. Have you updated the GPU drivers and the linux-headers etc. as well.
    – NetIceCat
    Commented Oct 21, 2019 at 8:27
  • 2
    Can you try with a much reduced Pixclock xrandr --newmode "2560x1440_RED" 140.500 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync , xrandr --addmode HDMI-3 "2560x1440_RED" , and xrandr --output HDMI-3 --mode 2560x1440_RED To see if it will even try to produce an output. I had to force a pixclock of 100Mhz on mine to attempt to force that resolultion,
    – NetIceCat
    Commented Oct 23, 2019 at 17:40
  • 1
    Here are two additional modelines you can try in the meantime, while I try to find the limiting factor: xrandr --newmode "2560x1440_54.97" 221.00 2560 2608 2640 2720 1440 1443 1447 1478 +HSync -VSync and xrandr --newmode "2560x1440_49.95" 200.25 2560 2608 2640 2720 1440 1443 1447 1474 +HSync -VSync . It is very likely that the 55Hz will be displayed.
    – NetIceCat
    Commented Oct 24, 2019 at 3:43
4

This post was very useful for me, especially the table down there where you can read HDMI v1.4 pixel clock maximum 340MHz. My monitor does only 250MHz maximum pixel clock. This forced me to realize that "cvt" tool is trying impossible:

> cvt 2560 1440 75
# 2560x1440 74.94 Hz (CVT 3.69M9) hsync: 112.86 kHz; pclk: 397.25 MHz
Modeline "2560x1440_75.00"  397.25  2560 2760 3040 3520  1440 1443 1448 1506 -hsync +vsync

Look, it is even saying 397.25MHz. Where does it come from? Well, calculate:

3520 * 1506 * 75 = 397.25MHz

The monitor spec clearly supports 2560 x 1440 @ 75Hz, maximum 250MHz pixel clock. "cvt" requires nearly 400MHz for this resolution. As you can feel something does not match here. It is blanking. There is so much blanking which drives the pixel clock to the sky.

Realized the cvt tool does provide option to reduce blanking "-r". However when I tried to use it I got a message:

ERROR: Multiple of 60Hz refresh rate required for  reduced blanking.

Luckily this post was helpful again:

> edid-decode /sys/class/drm/card0-HDMI-A-1/edid
Detailed mode: Clock 296.000 MHz, 725 mm x 428 mm
               2560 2568 2600 2666 hborder 0
               1440 1443 1448 1481 vborder 0
               +hsync -vsync

The rest is piece of cake. The mode should be:

Modeline "2560x1440_75.00" 296.0 2560 2568 2600 2666  1440 1443 1448 1481  +hsync -vsync

We can verify:

296000000 / 2666 / 1481 = 74Hz

And yes, indeed this finally worked. Machine Dell Inspiron 5379 was running Ubuntu with built in driver i920 for Intel UHD Graphics 620.

What stays dark for me are the reasons behind this. You can guess why I had to go this deep. The Ubuntu settings maximum resolution was / is only Full HD, i.e. 1920 x 1080 @ 60Hz. I wanted to go native with my monitor. I would expect this to work out of the box. The maximum resolution I needed is simply missing from the list and the web was not very helpful this time around.

1
  • This (Ubuntu settings max resolution) may be because this is your graphics card maximum official resolution. Ubuntu goes by the list of supported settings, while manual config allows to go beyond that.
    – Dmitriy
    Commented Sep 30, 2020 at 20:24
-1

I was trying to change the resolution to 2560x1440 and it worked for me using the following command:

xrandr -s 2560x1440
-1

Despite all my efforts, the screen remained black. I could see the new resolution in the system settings after the changes with xrandr, but as soon as they were selected, the screen went black.

My screen is connected with DVI. However, I only had a simple DVI cable. After I connected a DVI-D dual link cable, even the highest resolution of 2560x1440 was no longer a problem. The resolution is now automatically set by the system.

-2

$ xrandr --newmode "2560x1440" 241.500 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync $ xrandr --addmode Virtual1 "2560x1440" $ xrandr --output Virtual1 --mode 2560x1440

-2

xrandr --newmode "2560x1440" 241.500 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync ; xrandr --addmode Virtual1 "2560x1440" ; xrandr --output Virtual1 --mode 2560x1440

should be like this

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .