0

I am trying to connect to an instance of SQL Server 17 running on my Ubuntu 18.04 machine, using Azure Data Studio, and after a long session of brainstorming, I discovered that it depends upon OpenSSL 1.1.0, where as the one which I have installed is OpenSSL 1.1.1-1ubuntu2.1~18.04.4.

Now, all I did was sudo apt-get install openssl 1.1.0, in the hopes that two versions of the same library may be allowed in Linux, but as expected, Linux never does what you would expect out of a normal operating system, and instead gave me a long error message, which I am copy-pasting below.

How to insttal it? I need to clean all the broken packages, undo any mess that I may have created, and I just hope to make the database connection work normally.

The error message is as below:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libghc-zip-archive-prof-0.3.1.1-0861f' for regex '1.1.0'
Note, selecting 'libghc-profunctors-prof-5.2.1-18027' for regex '1.1.0'
Note, selecting 'libghc-reactive-banana-prof-1.1.0.1-314dd' for regex '1.1.0'
Note, selecting 'libghc-objectname-prof-1.1.0.1-ea2c6:i386' for regex '1.1.0'
Note, selecting 'libghc-torrent-prof-10000.1.1-08340:i386' for regex '1.1.0'
Note, selecting 'libghc-unbounded-delays-prof-0.1.1.0-e7cb4' for regex '1.1.0'
Note, selecting 'libghc-convertible-dev-1.1.1.0-7413a:i386' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha256-prof-0.11.101.0-98d30' for regex '1.1.0'
Note, selecting 'libghc-statevar-prof-1.1.0.4-2374a:i386' for regex '1.1.0'
Note, selecting 'libghc-heist-prof-1.0.1.1-05a1c' for regex '1.1.0'
Note, selecting 'gir1.2-clutterx11-1.0' for regex '1.1.0'
Note, selecting 'libghc-convertible-prof-1.1.1.0-7413a:i386' for regex '1.1.0'
Note, selecting 'libghc-statevar-dev-1.1.0.4-93f6c' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha1-prof-0.11.100.1-44c39:i386' for regex '1.1.0'
Note, selecting 'libghc-unliftio-dev-0.1.1.0-c2f1f' for regex '1.1.0'
Note, selecting 'libghc-unliftio-dev-0.1.1.0-18213:i386' for regex '1.1.0'
Note, selecting 'libghc-assert-failure-dev-0.1.1.0-e78d8:i386' for regex '1.1.0'
Note, selecting 'libghc-wl-pprint-text-prof-1.1.1.0-36c22' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha1-dev-0.11.100.1-c80f9' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-md5-prof-0.11.100.1-94c4c' for regex '1.1.0'
Note, selecting 'libghc-template-haskell-prof-2.11.1.0-14f6d' for regex '1.1.0'
Note, selecting 'libghc-ieee754-prof-0.8.0-1e190' for regex '1.1.0'
Note, selecting 'libghc-assert-failure-prof-0.1.1.0-e78d8:i386' for regex '1.1.0'
Note, selecting 'libghc-template-haskell-prof-2.11.1.0-ae950:i386' for regex '1.1.0'
Note, selecting 'libghc-torrent-dev-10000.1.1-08340:i386' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-md5-dev-0.11.100.1-94c4c' for regex '1.1.0'
Note, selecting 'libghc-text-binary-dev-0.2.1.1-03183' for regex '1.1.0'
Note, selecting 'xfonts-cronyx-cp1251-100dpi' for regex '1.1.0'
Note, selecting 'dotnet-sdk-2.1.100' for regex '1.1.0'
Note, selecting 'libghc-charsetdetect-ae-prof-1.1.0.3-dca53' for regex '1.1.0'
Note, selecting 'libghc-persistable-record-dev-0.5.1.1-033c0:i386' for regex '1.1.0'
Note, selecting 'libghc-template-haskell-dev-2.11.1.0-14f6d' for regex '1.1.0'
Note, selecting 'libghc-convertible-dev-1.1.1.0-172e8' for regex '1.1.0'
Note, selecting 'libghc-assert-failure-dev-0.1.1.0-92d36' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha256-dev-0.11.101.0-be75d:i386' for regex '1.1.0'
Note, selecting 'libghc-magic-dev-1.1-00f95' for regex '1.1.0'
Note, selecting 'libghc-template-haskell-dev-2.11.1.0-ae950:i386' for regex '1.1.0'
Note, selecting 'libfreerdp-common1.1.0' for regex '1.1.0'
Note, selecting 'libghc-charsetdetect-ae-dev-1.1.0.3-dca53' for regex '1.1.0'
Note, selecting 'libghc-convertible-prof-1.1.1.0-172e8' for regex '1.1.0'
Note, selecting 'libghc-assert-failure-prof-0.1.1.0-92d36' for regex '1.1.0'
Note, selecting 'libghc-objectname-dev-1.1.0.1-034f1' for regex '1.1.0'
Note, selecting 'libghc-old-time-prof-1.1.0.3-d6447:i386' for regex '1.1.0'
Note, selecting 'libghc-profunctors-dev-5.2.1-18027' for regex '1.1.0'
Note, selecting 'libghc-magic-prof-1.1-00f95' for regex '1.1.0'
Note, selecting 'libghc-wl-pprint-text-dev-1.1.1.0-29ea7:i386' for regex '1.1.0'
Note, selecting 'libghc-statevar-prof-1.1.0.4-93f6c' for regex '1.1.0'
Note, selecting 'libghc-heist-dev-1.0.1.1-05a1c' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-md5-prof-0.11.100.1-caa81:i386' for regex '1.1.0'
Note, selecting 'libghc-old-time-prof-1.1.0.3-a85e0' for regex '1.1.0'
Note, selecting 'libghc-ieee754-dev-0.8.0-1e190' for regex '1.1.0'
Note, selecting 'libghc-reactive-banana-dev-1.1.0.1-ef8d4:i386' for regex '1.1.0'
Note, selecting 'libghc-persistable-record-prof-0.5.1.1-033c0:i386' for regex '1.1.0'
Note, selecting 'libghc-old-time-dev-1.1.0.3-d6447:i386' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha256-dev-0.11.101.0-98d30' for regex '1.1.0'
Note, selecting 'libghc-vector-prof-0.12.0.1-190d1:i386' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-md5-dev-0.11.100.1-caa81:i386' for regex '1.1.0'
Note, selecting 'libghc-old-time-dev-1.1.0.3-a85e0' for regex '1.1.0'
Note, selecting 'libghc-unbounded-delays-dev-0.1.1.0-14b4a:i386' for regex '1.1.0'
Note, selecting 'libghc-cprng-aes-prof-0.6.1-1c008:i386' for regex '1.1.0'
Note, selecting 'libghc-zip-archive-dev-0.3.1.1-0861f' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha1-prof-0.11.100.1-c80f9' for regex '1.1.0'
Note, selecting 'libghc-reactive-banana-dev-1.1.0.1-314dd' for regex '1.1.0'
Note, selecting 'libghc-interpolate-dev-0.1.1-00566' for regex '1.1.0'
Note, selecting 'libghc-unliftio-prof-0.1.1.0-c2f1f' for regex '1.1.0'
Note, selecting 'dotnet-hostfxr-1.1.0' for regex '1.1.0'
Note, selecting 'libghc-unliftio-prof-0.1.1.0-18213:i386' for regex '1.1.0'
Note, selecting 'libghc-cprng-aes-dev-0.6.1-1c008:i386' for regex '1.1.0'
Note, selecting 'libghc-bindings-nettle-dev-0.3.1-1e0b5:i386' for regex '1.1.0'
Note, selecting 'libghc-text-binary-prof-0.2.1.1-03183' for regex '1.1.0'
Note, selecting 'libghc-objectname-dev-1.1.0.1-ea2c6:i386' for regex '1.1.0'
Note, selecting 'libghc-charsetdetect-ae-prof-1.1.0.3-990b9:i386' for regex '1.1.0'
Note, selecting 'libghc-statevar-dev-1.1.0.4-2374a:i386' for regex '1.1.0'
Note, selecting 'libghc-wl-pprint-text-dev-1.1.1.0-36c22' for regex '1.1.0'
Note, selecting 'libghc-charsetdetect-ae-dev-1.1.0.3-990b9:i386' for regex '1.1.0'
Note, selecting 'libghc-objectname-prof-1.1.0.1-034f1' for regex '1.1.0'
Note, selecting 'libghc-vector-dev-0.12.0.1-190d1:i386' for regex '1.1.0'
Note, selecting 'libghc-unbounded-delays-prof-0.1.1.0-14b4a:i386' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha1-dev-0.11.100.1-44c39:i386' for regex '1.1.0'
Note, selecting 'libghc-bindings-nettle-prof-0.3.1-1e0b5:i386' for regex '1.1.0'
Note, selecting 'libghc-interpolate-prof-0.1.1-00566' for regex '1.1.0'
Note, selecting 'libghc-unbounded-delays-dev-0.1.1.0-e7cb4' for regex '1.1.0'
Note, selecting 'libghc-cryptohash-sha256-prof-0.11.101.0-be75d:i386' for regex '1.1.0'
Note, selecting 'libghc-reactive-banana-prof-1.1.0.1-ef8d4:i386' for regex '1.1.0'
Note, selecting 'libghc-wl-pprint-text-prof-1.1.1.0-29ea7:i386' for regex '1.1.0'
Note, selecting 'gir1.2-clutter-1.0' instead of 'gir1.2-clutterx11-1.0'
Note, selecting 'ghc' instead of 'libghc-template-haskell-dev-2.11.1.0-14f6d'
Note, selecting 'ghc-prof' instead of 'libghc-template-haskell-prof-2.11.1.0-14f6d'
Note, selecting 'libghc-profunctors-dev' instead of 'libghc-profunctors-dev-5.2.1-18027'
Note, selecting 'libghc-profunctors-prof' instead of 'libghc-profunctors-prof-5.2.1-18027'
Note, selecting 'libghc-ieee754-dev' instead of 'libghc-ieee754-dev-0.8.0-1e190'
Note, selecting 'libghc-assert-failure-dev' instead of 'libghc-assert-failure-dev-0.1.1.0-92d36'
Note, selecting 'libghc-assert-failure-prof' instead of 'libghc-assert-failure-prof-0.1.1.0-92d36'
Note, selecting 'libghc-text-binary-dev' instead of 'libghc-text-binary-dev-0.2.1.1-03183'
Note, selecting 'libghc-text-binary-prof' instead of 'libghc-text-binary-prof-0.2.1.1-03183'
Note, selecting 'libghc-charsetdetect-ae-dev' instead of 'libghc-charsetdetect-ae-dev-1.1.0.3-dca53'
Note, selecting 'libghc-charsetdetect-ae-prof' instead of 'libghc-charsetdetect-ae-prof-1.1.0.3-dca53'
Note, selecting 'libghc-statevar-dev' instead of 'libghc-statevar-dev-1.1.0.4-93f6c'
Note, selecting 'libghc-statevar-prof' instead of 'libghc-statevar-prof-1.1.0.4-93f6c'
Note, selecting 'libghc-old-time-dev' instead of 'libghc-old-time-dev-1.1.0.3-a85e0'
Note, selecting 'libghc-convertible-dev' instead of 'libghc-convertible-dev-1.1.1.0-172e8'
Note, selecting 'libghc-old-time-prof' instead of 'libghc-old-time-prof-1.1.0.3-a85e0'
Note, selecting 'libghc-convertible-prof' instead of 'libghc-convertible-prof-1.1.1.0-172e8'
Note, selecting 'libghc-ieee754-prof' instead of 'libghc-ieee754-prof-0.8.0-1e190'
Note, selecting 'libghc-cryptohash-md5-dev' instead of 'libghc-cryptohash-md5-dev-0.11.100.1-94c4c'
Note, selecting 'libghc-cryptohash-md5-prof' instead of 'libghc-cryptohash-md5-prof-0.11.100.1-94c4c'
Note, selecting 'libghc-cryptohash-sha1-dev' instead of 'libghc-cryptohash-sha1-dev-0.11.100.1-c80f9'
Note, selecting 'libghc-cryptohash-sha1-prof' instead of 'libghc-cryptohash-sha1-prof-0.11.100.1-c80f9'
Note, selecting 'libghc-cryptohash-sha256-dev' instead of 'libghc-cryptohash-sha256-dev-0.11.101.0-98d30'
Note, selecting 'libghc-cryptohash-sha256-prof' instead of 'libghc-cryptohash-sha256-prof-0.11.101.0-98d30'
Note, selecting 'libghc-wl-pprint-text-dev' instead of 'libghc-wl-pprint-text-dev-1.1.1.0-36c22'
Note, selecting 'libghc-wl-pprint-text-prof' instead of 'libghc-wl-pprint-text-prof-1.1.1.0-36c22'
Note, selecting 'libghc-heist-dev' instead of 'libghc-heist-dev-1.0.1.1-05a1c'
Note, selecting 'libghc-heist-prof' instead of 'libghc-heist-prof-1.0.1.1-05a1c'
Note, selecting 'libghc-interpolate-dev' instead of 'libghc-interpolate-dev-0.1.1-00566'
Note, selecting 'libghc-interpolate-prof' instead of 'libghc-interpolate-prof-0.1.1-00566'
Note, selecting 'libghc-magic-dev' instead of 'libghc-magic-dev-1.1-00f95'
Note, selecting 'libghc-magic-prof' instead of 'libghc-magic-prof-1.1-00f95'
Note, selecting 'libghc-unliftio-dev' instead of 'libghc-unliftio-dev-0.1.1.0-c2f1f'
Note, selecting 'libghc-unliftio-prof' instead of 'libghc-unliftio-prof-0.1.1.0-c2f1f'
Note, selecting 'libghc-objectname-dev' instead of 'libghc-objectname-dev-1.1.0.1-034f1'
Note, selecting 'libghc-objectname-prof' instead of 'libghc-objectname-prof-1.1.0.1-034f1'
Note, selecting 'libghc-zip-archive-dev' instead of 'libghc-zip-archive-dev-0.3.1.1-0861f'
Note, selecting 'libghc-zip-archive-prof' instead of 'libghc-zip-archive-prof-0.3.1.1-0861f'
Note, selecting 'libghc-reactive-banana-dev' instead of 'libghc-reactive-banana-dev-1.1.0.1-314dd'
Note, selecting 'libghc-reactive-banana-prof' instead of 'libghc-reactive-banana-prof-1.1.0.1-314dd'
Note, selecting 'libghc-unbounded-delays-dev' instead of 'libghc-unbounded-delays-dev-0.1.1.0-e7cb4'
Note, selecting 'libghc-unbounded-delays-prof' instead of 'libghc-unbounded-delays-prof-0.1.1.0-e7cb4'
Note, selecting 'ghc:i386' instead of 'libghc-template-haskell-dev-2.11.1.0-ae950:i386'
Note, selecting 'ghc-prof:i386' instead of 'libghc-template-haskell-prof-2.11.1.0-ae950:i386'
Note, selecting 'libghc-vector-dev:i386' instead of 'libghc-vector-dev-0.12.0.1-190d1:i386'
Note, selecting 'libghc-vector-prof:i386' instead of 'libghc-vector-prof-0.12.0.1-190d1:i386'
Note, selecting 'libghc-assert-failure-dev:i386' instead of 'libghc-assert-failure-dev-0.1.1.0-e78d8:i386'
Note, selecting 'libghc-assert-failure-prof:i386' instead of 'libghc-assert-failure-prof-0.1.1.0-e78d8:i386'
Note, selecting 'libghc-bindings-nettle-dev:i386' instead of 'libghc-bindings-nettle-dev-0.3.1-1e0b5:i386'
Note, selecting 'libghc-bindings-nettle-prof:i386' instead of 'libghc-bindings-nettle-prof-0.3.1-1e0b5:i386'
Note, selecting 'libghc-charsetdetect-ae-dev:i386' instead of 'libghc-charsetdetect-ae-dev-1.1.0.3-990b9:i386'
Note, selecting 'libghc-charsetdetect-ae-prof:i386' instead of 'libghc-charsetdetect-ae-prof-1.1.0.3-990b9:i386'
Note, selecting 'libghc-cprng-aes-dev:i386' instead of 'libghc-cprng-aes-dev-0.6.1-1c008:i386'
Note, selecting 'libghc-cprng-aes-prof:i386' instead of 'libghc-cprng-aes-prof-0.6.1-1c008:i386'
Note, selecting 'libghc-statevar-dev:i386' instead of 'libghc-statevar-dev-1.1.0.4-2374a:i386'
Note, selecting 'libghc-statevar-prof:i386' instead of 'libghc-statevar-prof-1.1.0.4-2374a:i386'
Note, selecting 'libghc-old-time-dev:i386' instead of 'libghc-old-time-dev-1.1.0.3-d6447:i386'
Note, selecting 'libghc-convertible-dev:i386' instead of 'libghc-convertible-dev-1.1.1.0-7413a:i386'
Note, selecting 'libghc-old-time-prof:i386' instead of 'libghc-old-time-prof-1.1.0.3-d6447:i386'
Note, selecting 'libghc-convertible-prof:i386' instead of 'libghc-convertible-prof-1.1.1.0-7413a:i386'
Note, selecting 'libghc-cryptohash-md5-dev:i386' instead of 'libghc-cryptohash-md5-dev-0.11.100.1-caa81:i386'
Note, selecting 'libghc-cryptohash-md5-prof:i386' instead of 'libghc-cryptohash-md5-prof-0.11.100.1-caa81:i386'
Note, selecting 'libghc-cryptohash-sha1-dev:i386' instead of 'libghc-cryptohash-sha1-dev-0.11.100.1-44c39:i386'
Note, selecting 'libghc-cryptohash-sha1-prof:i386' instead of 'libghc-cryptohash-sha1-prof-0.11.100.1-44c39:i386'
Note, selecting 'libghc-cryptohash-sha256-dev:i386' instead of 'libghc-cryptohash-sha256-dev-0.11.101.0-be75d:i386'
Note, selecting 'libghc-cryptohash-sha256-prof:i386' instead of 'libghc-cryptohash-sha256-prof-0.11.101.0-be75d:i386'
Note, selecting 'libghc-wl-pprint-text-dev:i386' instead of 'libghc-wl-pprint-text-dev-1.1.1.0-29ea7:i386'
Note, selecting 'libghc-wl-pprint-text-prof:i386' instead of 'libghc-wl-pprint-text-prof-1.1.1.0-29ea7:i386'
Note, selecting 'libghc-unliftio-dev:i386' instead of 'libghc-unliftio-dev-0.1.1.0-18213:i386'
Note, selecting 'libghc-unliftio-prof:i386' instead of 'libghc-unliftio-prof-0.1.1.0-18213:i386'
Note, selecting 'libghc-objectname-dev:i386' instead of 'libghc-objectname-dev-1.1.0.1-ea2c6:i386'
Note, selecting 'libghc-objectname-prof:i386' instead of 'libghc-objectname-prof-1.1.0.1-ea2c6:i386'
Note, selecting 'libghc-persistable-record-dev:i386' instead of 'libghc-persistable-record-dev-0.5.1.1-033c0:i386'
Note, selecting 'libghc-persistable-record-prof:i386' instead of 'libghc-persistable-record-prof-0.5.1.1-033c0:i386'
Note, selecting 'libghc-reactive-banana-dev:i386' instead of 'libghc-reactive-banana-dev-1.1.0.1-ef8d4:i386'
Note, selecting 'libghc-reactive-banana-prof:i386' instead of 'libghc-reactive-banana-prof-1.1.0.1-ef8d4:i386'
Note, selecting 'libghc-unbounded-delays-dev:i386' instead of 'libghc-unbounded-delays-dev-0.1.1.0-14b4a:i386'
Note, selecting 'libghc-unbounded-delays-prof:i386' instead of 'libghc-unbounded-delays-prof-0.1.1.0-14b4a:i386'
Note, selecting 'libghc-torrent-dev:i386' instead of 'libghc-torrent-dev-10000.1.1-08340:i386'
Note, selecting 'libghc-torrent-prof:i386' instead of 'libghc-torrent-prof-10000.1.1-08340:i386'
openssl is already the newest version (1.1.1-1ubuntu2.1~18.04.4).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dotnet-sdk-2.1.100 : Depends: dotnet-runtime-2.0.5 but it is not going to be installed
 ghc : Conflicts: ghc:i386 but 8.0.2-11 is to be installed
 ghc:i386 : Depends: gcc:i386 but it is not going to be installed
            Conflicts: ghc but 8.0.2-11 is to be installed
 ghc-prof : Conflicts: ghc-prof:i386 but 8.0.2-11 is to be installed
 ghc-prof:i386 : Conflicts: ghc-prof but 8.0.2-11 is to be installed
 libghc-assert-failure-dev : Depends: libghc-pretty-show-dev-1.6.15-6894a
                             Depends: libghc-text-dev-1.2.2.2-5429b
                             Conflicts: libghc-assert-failure-dev:i386 but 0.1.1.0-1build2 is to be installed
 libghc-assert-failure-dev:i386 : Conflicts: libghc-assert-failure-dev but 0.1.1.0-1build2 is to be installed
 libghc-assert-failure-prof : Depends: libghc-pretty-show-prof-1.6.15-6894a
                              Depends: libghc-text-prof-1.2.2.2-5429b
                              Conflicts: libghc-assert-failure-prof:i386 but 0.1.1.0-1build2 is to be installed
 libghc-assert-failure-prof:i386 : Conflicts: libghc-assert-failure-prof but 0.1.1.0-1build2 is to be installed
 libghc-charsetdetect-ae-dev : Conflicts: libghc-charsetdetect-ae-dev:i386 but 1.1.0.3-1 is to be installed
 libghc-charsetdetect-ae-dev:i386 : Conflicts: libghc-charsetdetect-ae-dev but 1.1.0.3-1 is to be installed
 libghc-charsetdetect-ae-prof : Conflicts: libghc-charsetdetect-ae-prof:i386 but 1.1.0.3-1 is to be installed
 libghc-charsetdetect-ae-prof:i386 : Conflicts: libghc-charsetdetect-ae-prof but 1.1.0.3-1 is to be installed
 libghc-convertible-dev : Depends: libghc-text-dev-1.2.2.2-5429b
                          Conflicts: libghc-convertible-dev:i386 but 1.1.1.0-5build2 is to be installed
 libghc-convertible-dev:i386 : Depends: libghc-mtl-dev-2.2.1-93d32:i386
                               Depends: libghc-old-locale-dev-1.0.0.7-caf13:i386
                               Conflicts: libghc-convertible-dev but 1.1.1.0-5build2 is to be installed
 libghc-convertible-prof : Depends: libghc-text-prof-1.2.2.2-5429b
                           Conflicts: libghc-convertible-prof:i386 but 1.1.1.0-5build2 is to be installed
 libghc-convertible-prof:i386 : Depends: libghc-mtl-prof-2.2.1-93d32:i386
                                Depends: libghc-old-locale-prof-1.0.0.7-caf13:i386
                                Conflicts: libghc-convertible-prof but 1.1.1.0-5build2 is to be installed
 libghc-cryptohash-md5-dev : Conflicts: libghc-cryptohash-md5-dev:i386 but 0.11.100.1-1 is to be installed
 libghc-cryptohash-md5-dev:i386 : Conflicts: libghc-cryptohash-md5-dev but 0.11.100.1-1 is to be installed
 libghc-cryptohash-md5-prof : Conflicts: libghc-cryptohash-md5-prof:i386 but 0.11.100.1-1 is to be installed
 libghc-cryptohash-md5-prof:i386 : Conflicts: libghc-cryptohash-md5-prof but 0.11.100.1-1 is to be installed
 libghc-cryptohash-sha1-dev : Conflicts: libghc-cryptohash-sha1-dev:i386 but 0.11.100.1-1 is to be installed
 libghc-cryptohash-sha1-dev:i386 : Conflicts: libghc-cryptohash-sha1-dev but 0.11.100.1-1 is to be installed
 libghc-cryptohash-sha1-prof : Conflicts: libghc-cryptohash-sha1-prof:i386 but 0.11.100.1-1 is to be installed
 libghc-cryptohash-sha1-prof:i386 : Conflicts: libghc-cryptohash-sha1-prof but 0.11.100.1-1 is to be installed
 libghc-cryptohash-sha256-dev : Conflicts: libghc-cryptohash-sha256-dev:i386 but 0.11.101.0-1 is to be installed
 libghc-cryptohash-sha256-dev:i386 : Conflicts: libghc-cryptohash-sha256-dev but 0.11.101.0-1 is to be installed
 libghc-cryptohash-sha256-prof : Conflicts: libghc-cryptohash-sha256-prof:i386 but 0.11.101.0-1 is to be installed
 libghc-cryptohash-sha256-prof:i386 : Conflicts: libghc-cryptohash-sha256-prof but 0.11.101.0-1 is to be installed
 libghc-heist-dev : Depends: libghc-aeson-dev-1.1.2.0-165b0
                    Depends: libghc-attoparsec-dev-0.13.1.0-822ef
                    Depends: libghc-blaze-builder-dev-0.4.0.2-2693c
                    Depends: libghc-blaze-html-dev-0.9.0.1-111c3
                    Depends: libghc-dlist-dev-0.8.0.3-6a8a7
                    Depends: libghc-hashable-dev-1.2.6.1-04604
                    Depends: libghc-lifted-base-dev-0.2.3.11-da003
                    Depends: libghc-monad-control-dev-1.0.2.2-548a1
                    Depends: libghc-text-dev-1.2.2.2-5429b
                    Depends: libghc-transformers-base-dev-0.4.4-95437
                    Depends: libghc-unordered-containers-dev-0.2.8.0-40548
                    Depends: libghc-vector-dev-0.12.0.1-fac62
                    Depends: libghc-xmlhtml-dev-0.2.5.2-da7b9
 libghc-heist-prof : Depends: libghc-aeson-prof-1.1.2.0-165b0
                     Depends: libghc-attoparsec-prof-0.13.1.0-822ef
                     Depends: libghc-blaze-builder-prof-0.4.0.2-2693c
                     Depends: libghc-blaze-html-prof-0.9.0.1-111c3
                     Depends: libghc-dlist-prof-0.8.0.3-6a8a7
                     Depends: libghc-hashable-prof-1.2.6.1-04604
                     Depends: libghc-lifted-base-prof-0.2.3.11-da003
                     Depends: libghc-monad-control-prof-1.0.2.2-548a1
                     Depends: libghc-text-prof-1.2.2.2-5429b
                     Depends: libghc-transformers-base-prof-0.4.4-95437
                     Depends: libghc-unordered-containers-prof-0.2.8.0-40548
                     Depends: libghc-vector-prof-0.12.0.1-fac62
                     Depends: libghc-xmlhtml-prof-0.2.5.2-da7b9
 libghc-interpolate-dev : Depends: libghc-haskell-src-meta-dev-0.8.0.1-a96b7
 libghc-interpolate-prof : Depends: libghc-haskell-src-meta-prof-0.8.0.1-a96b7
 libghc-objectname-dev : Conflicts: libghc-objectname-dev:i386 but 1.1.0.1-3build1 is to be installed
 libghc-objectname-dev:i386 : Conflicts: libghc-objectname-dev but 1.1.0.1-3build1 is to be installed
 libghc-objectname-prof : Conflicts: libghc-objectname-prof:i386 but 1.1.0.1-3build1 is to be installed
 libghc-objectname-prof:i386 : Conflicts: libghc-objectname-prof but 1.1.0.1-3build1 is to be installed
 libghc-old-time-dev : Conflicts: libghc-old-time-dev:i386 but 1.1.0.3-5build1 is to be installed
 libghc-old-time-dev:i386 : Depends: libghc-old-locale-dev-1.0.0.7-caf13:i386
                            Conflicts: libghc-old-time-dev but 1.1.0.3-5build1 is to be installed
 libghc-old-time-prof : Conflicts: libghc-old-time-prof:i386 but 1.1.0.3-5build1 is to be installed
 libghc-old-time-prof:i386 : Depends: libghc-old-locale-prof-1.0.0.7-caf13:i386
                             Conflicts: libghc-old-time-prof but 1.1.0.3-5build1 is to be installed
 libghc-reactive-banana-dev : Depends: libghc-hashable-dev-1.2.6.1-04604
                              Depends: libghc-unordered-containers-dev-0.2.8.0-40548
                              Depends: libghc-vault-dev-0.3.0.7-e3391
                              Conflicts: libghc-reactive-banana-dev:i386 but 1.1.0.1-2build4 is to be installed
 libghc-reactive-banana-dev:i386 : Depends: libghc-pqueue-dev-1.3.2.3-ac30e:i386
                                   Depends: libghc-vault-dev-0.3.0.7-eba5a:i386
                                   Conflicts: libghc-reactive-banana-dev but 1.1.0.1-2build4 is to be installed
 libghc-reactive-banana-prof : Depends: libghc-hashable-prof-1.2.6.1-04604
                               Depends: libghc-unordered-containers-prof-0.2.8.0-40548
                               Depends: libghc-vault-prof-0.3.0.7-e3391
                               Conflicts: libghc-reactive-banana-prof:i386 but 1.1.0.1-2build4 is to be installed
 libghc-reactive-banana-prof:i386 : Depends: libghc-pqueue-prof-1.3.2.3-ac30e:i386
                                    Depends: libghc-vault-prof-0.3.0.7-eba5a:i386
                                    Conflicts: libghc-reactive-banana-prof but 1.1.0.1-2build4 is to be installed
 libghc-statevar-dev : Conflicts: libghc-statevar-dev:i386 but 1.1.0.4-4build1 is to be installed
 libghc-statevar-dev:i386 : Depends: libghc-stm-dev-2.4.4.1-84028:i386
                            Conflicts: libghc-statevar-dev but 1.1.0.4-4build1 is to be installed
 libghc-statevar-prof : Conflicts: libghc-statevar-prof:i386 but 1.1.0.4-4build1 is to be installed
 libghc-statevar-prof:i386 : Depends: libghc-stm-prof-2.4.4.1-84028:i386
                             Conflicts: libghc-statevar-prof but 1.1.0.4-4build1 is to be installed
 libghc-text-binary-dev : Depends: libghc-text-dev-1.2.2.2-5429b
 libghc-text-binary-prof : Depends: libghc-text-prof-1.2.2.2-5429b
 libghc-torrent-dev:i386 : Depends: libghc-bencode-dev-0.6.0.0-07211:i386
                           Depends: libghc-syb-dev-0.7-caee6:i386
 libghc-torrent-prof:i386 : Depends: libghc-bencode-prof-0.6.0.0-07211:i386
                            Depends: libghc-syb-prof-0.7-caee6:i386
 libghc-unbounded-delays-dev : Conflicts: libghc-unbounded-delays-dev:i386 but 0.1.1.0-1 is to be installed
 libghc-unbounded-delays-dev:i386 : Conflicts: libghc-unbounded-delays-dev but 0.1.1.0-1 is to be installed
 libghc-unbounded-delays-prof : Conflicts: libghc-unbounded-delays-prof:i386 but 0.1.1.0-1 is to be installed
 libghc-unbounded-delays-prof:i386 : Conflicts: libghc-unbounded-delays-prof but 0.1.1.0-1 is to be installed
 libghc-unliftio-dev : Depends: libghc-monad-logger-dev-0.3.25.1-fe6e4
                       Depends: libghc-resourcet-dev-1.1.9-53ff1
                       Depends: libghc-unliftio-core-dev-0.1.0.0-c589d
                       Conflicts: libghc-unliftio-dev:i386 but 0.1.1.0-1build1 is to be installed
 libghc-unliftio-dev:i386 : Depends: libghc-async-dev-2.1.1.1-dfd28:i386
                            Depends: libghc-monad-logger-dev-0.3.25.1-128fc:i386
                            Depends: libghc-resourcet-dev-1.1.9-a9bf0:i386
                            Conflicts: libghc-unliftio-dev but 0.1.1.0-1build1 is to be installed
 libghc-unliftio-prof : Depends: libghc-monad-logger-prof-0.3.25.1-fe6e4
                        Depends: libghc-resourcet-prof-1.1.9-53ff1
                        Depends: libghc-unliftio-core-prof-0.1.0.0-c589d
                        Conflicts: libghc-unliftio-prof:i386 but 0.1.1.0-1build1 is to be installed
 libghc-unliftio-prof:i386 : Depends: libghc-async-prof-2.1.1.1-dfd28:i386
                             Depends: libghc-monad-logger-prof-0.3.25.1-128fc:i386
                             Depends: libghc-resourcet-prof-1.1.9-a9bf0:i386
                             Conflicts: libghc-unliftio-prof but 0.1.1.0-1build1 is to be installed
 libghc-wl-pprint-text-dev : Depends: libghc-base-compat-dev-0.9.3-8575a
                             Depends: libghc-text-dev-1.2.2.2-5429b
                             Conflicts: libghc-wl-pprint-text-dev:i386 but 1.1.1.0-1build1 is to be installed
 libghc-wl-pprint-text-dev:i386 : Conflicts: libghc-wl-pprint-text-dev but 1.1.1.0-1build1 is to be installed
 libghc-wl-pprint-text-prof : Depends: libghc-base-compat-prof-0.9.3-8575a
                              Depends: libghc-text-prof-1.2.2.2-5429b
                              Conflicts: libghc-wl-pprint-text-prof:i386 but 1.1.1.0-1build1 is to be installed
 libghc-wl-pprint-text-prof:i386 : Conflicts: libghc-wl-pprint-text-prof but 1.1.1.0-1build1 is to be installed
 libghc-zip-archive-dev : Depends: libghc-text-dev-1.2.2.2-5429b
                          Depends: libghc-zlib-dev-0.6.1.2-a4a43
 libghc-zip-archive-prof : Depends: libghc-text-prof-1.2.2.2-5429b
                           Depends: libghc-zlib-prof-0.6.1.2-a4a43
E: Unable to correct problems, you have held broken packages.
4
  • The apt syntax for installing a specific package version is name=version rather than name version - see for example How to install specific Ubuntu packages, with exact version?. Regarding your specific issue with mssql-server see How can I ignore a package dependency? however. Oct 21 '19 at 2:24
  • [...] as expected, Linux never does what you would expect out of a normal operating system [...] . There is no objective definition of "normal", but besides that, as seen above, looking at the docs is always more helpful than criticizing.
    – schaiba
    Oct 21 '19 at 12:19
  • @steeldriver Alright, thanks for that info, but before I could reconfigure my installation of SQL Server, I want to fix all the broken packages that I am holding. How do I do that? I tried various commands, e.g. sudo apt-get clean AND sudo apt-get --fix-broken, but the former does not produce any result, whereas the latter produces an error which says "E: Command line option --fix-broken is not understood in combination with the other options". Can you please help me get rid of broken packages? Oct 21 '19 at 13:12
  • @schaiba Correct, but for a Linux beginner, the task of having to look things up for a simple installation is daunting. You have to look up almost anything and everything. Computers were made to make our lives easier, not more complicated. With Windows, you don't have to look up anything at all. Just go on clicking buttons, and hooray, it just works. It's what we call "Abstraction". I am more of a data guy. I shouldn't have to deal with the details of operating system, in the same way as a system administrator while working with Excel, does not have to deal with advanced math. Oct 21 '19 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.