0

I bought an Alfa AWUS1900 WLAN device for education purpose with Aircrack, because it has Linux support and some posts/reviews confirms that. Sadly I can't get the driver working in monitor mode, especially on the new 5er Kernel.

My setup

The notebook runs Ubunu 18.04.3 LTS with VirtualBox where I created a VM with the latest Kali Linux, which is 2019.3 at the time of writing. VirtualBox has the extension pack installed for USB 2 support. It runs as root for USB forwarding:

enter image description here

My chipset

Since I read reviews about users getting different chipsets for the same device type, I plugged the device in and verified to have the RTL8814AU chipset:

root@kali:~# lsusb | grep -E "Realtek*"
Bus 001 Device 002: ID 0bda:8813 Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac Wireless Adapter

Not working drivers

A snapshot was created before any driver was installed and after each non-working driver, I went back to the vanilla snapshot to have a clean system and make sure that no older driver influence the current one.

zebulon2/rtl8814au

This driver worked partially when using the Kali Linux snapshot image directly without upgrading packages (there are many updates avaliable). The device got detected and the network manager shows me avaliable APs as well as using nmcli dev wifi command. But the device is in managed mode:

root@kali:~/rtl8814au# iw dev | grep type
    type managed

I can't switch to monitor mode:

root@kali:~/rtl8814au# airmon-ng check kill
Killing these processes:

  PID Name
  831 wpa_supplicant

root@kali:~/rtl8814au# airmon-ng start wlan0
PHY Interface   Driver      Chipset

phy0    wlan0       rtl8814au   Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac

ERROR adding monitor mode interface: command failed: Operation not supported (-95) 

Even not with ifconfig:

root@kali:~/rtl8814au# ifconfig wlan0 down
root@kali:~/rtl8814au# iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not permitted.

dmesg lot entry when putting in monitor mode:

[  940.905187] RTL871X: ERROR HalPwrSeqCmdParsing: Fail to polling Offset[0x6]=00
[  940.905191] RTL871X: nolinked power save leave

Some posts mentioned a bug in airmon-ng but say it should work with ifconfig.

realtek-rtl88xxau-dkms

According to this thread in the kali forum, there is a package called realtek-rtl88xxau-dkms in the repos that should contain all required drivers. So I installed his dependencies like described here

apt install dkms &&
apt-get install bc &&
apt-get install build-essential &&
apt-get install linux-headers-$(uname -r) 

then the driver package using apt-get install realtek-rtl88xxau-dkms and plugged in my usb wifi device. I'm wondering that I get some error about missing module or filename, but it's not clear for me what exactly is missing and if it's required (since it says installation completed):

88XXau.ko:
Running module version sanity check.
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.2.0-kali3-amd64/updates/

depmod....

DKMS: install completed.

dmesg detects the new device, but after a few seconds it got disconnected:

[ 1080.147957] usb 1-1: new high-speed USB device number 4 using ehci-pci
[ 1080.595125] usb 1-1: New USB device found, idVendor=0bda, idProduct=8813, bcdDevice= 0.00
[ 1080.595131] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1080.595135] usb 1-1: Product: 802.11ac NIC
[ 1080.595136] usb 1-1: Manufacturer: Realtek
[ 1080.595137] usb 1-1: SerialNumber: 123456
[ 1087.695407] usb 1-1: USB disconnect, device number 4

On the first run, this was all I got. But the second approach shows also this VirtualBox error:

enter image description here

aircrack-ng/rtl8812au

I'm not sure if aircrack-ng/rtl8812au is the same driver as the realtek-rtl88xxau-dkms apt-package, so I tried ./dkms-install.sh there but also no luck, just similar issues.

Altough the snapshot of Kali Linux is outdated for several months (over 800 package updates for a vanilla installation), there seems no kernel update. The following kernel version is the same before and after updating all packages:

Linux kali 5.2.0-kali2-amd64 #1 SMP Debian 5.2.9-2kali1 (2019-08-22) x86_64 GNU/Linux
1

I could reproduce that the problem was caused by prodiving the wrong USB type in VirtualBox, which is the result of the following mistake: My chromebook has two USB ports. Both where black, so I assumed they were USB 2.0. The USB device supports 3.0, but should be downgraded to my 2.0 ports.

To be sure about this, I run on the host

lsusb | grep Realtek
Bus 002 Device 004: ID 0bda:8813 Realtek Semiconductor Corp.

which gave me the bus and device id to look for the specification:

sudo lsusb -D /dev/bus/usb/002/004 | grep bcdUSB
  bcdUSB               2.10

This was before initially setup the VM because I want to be sure to specify the correct USB type (never worked with forwarded USB devices on VirtualBox before). Since I spend several hours to make the driver work, I continued a day later and without noticing used the right USB port (instead of the left one, which I used yesterday). But the right port seems to be USB3, altough it itsn't colored blue because today, lsusb say to the Realtek device:

sudo lsusb -D /dev/bus/usb/002/004 | grep bcdUSB
  bcdUSB               3.00

So I switched the type of the USB controller in VirtualBox from 2.0 (EHCI) to 3.0 (xHCI) and everything worked with the realtek-rtl88xxau-dkms driver package, even with airmon directly:

root@kali:~# airmon-ng start wlan0
PHY Interface   Driver      Chipset

phy0    wlan0       88XXau      Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac
 (monitor mode enabled)

After I received the VirtualBox error (and not just the dmesg one), this ticket gave the right hint.

Lesson learned: Dont trust the socket colors in such situations! Verify the specification, especially when using other sockets during the work on the same project...

  • 1
    From the question is not clear whether you are playing Whac-A-Mole with drivers, however the answer is superb. +1 – Rui F Ribeiro Oct 20 '19 at 13:40
  • Thanks for your vote! The reason for trying multiple drivers is that the monitorring mode weren't work. I first thought this was caused by the drivers, but as dmesg first just say USB disconnect I assumed there went something wrong. – Lion Oct 20 '19 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.