1

I'm trying to install Linux Mint (Cinnamon) in VirtualBox. I have set up the machine and .iso, but when it boots it just shows a black screen with a blinking horizontal line. I had a similar issue trying to install Ubuntu the same way before.

I can open the menu by pressing e during autoboot, and can choose between several boot options (so far none resulted in success) and a command line which I'm not sure what to do with.

Now trying to leave it running for a while

Update:

  • OS of host = Windows 10
  • Version of VirtualBox =
  • Main settings of guest: 1024 MB of memory (I tried 4352, but then it crashes), 1 cpu, Linux Mint 19.2 Cinnamon

Also, here's the error message for the 4352 MB attempt:

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

  • Please provide the following (add to your question): OS of host, version of Virtualbox, main settings of guest (memory, CPUs, OS version). – ajgringo619 Oct 19 at 17:35
  • Have you checked logs? Copy and paste any you find relevant to question. (In VirtualBox select the machine and press Ctrl+L, or right-click and select logs) – user3342816 Oct 19 at 17:51
  • You need to enable VT-x/IOMMU in your BIOS, at a minimum. 1GB RAM is a little light for Cinnamon; I'd bump that to 2GB. – ajgringo619 Oct 19 at 18:13
  • @ajgringo619 Already set it to 2GB. How do I enable VT-x/IOMMU? – Dorijan Cirkveni Oct 19 at 18:15
  • @DorijanCirkveni - you'll need to consult your motherboard manual. – ajgringo619 Oct 19 at 18:18
0

Enabling VT in my BIOS (UEFI) helped me. (as suggested by user ajgringo) I enabled it while pressing F10 or F12, at the start up of the PC, on my Lenovo Laptop. Then I found it under the Boot-Settings, change to the setting with arrow keys. *Note: some old laptops don't have VT, since you run Win10 should be fine (should have VT and 64bit).

edit:

link from question owner to get into the BIOS/UEFI setting on different Laptops:

2nwiki.2n.cz/pages/viewpage.action?pageId=75202968

I don't know about the second error-code.

  • You should always be able to comment on your own questions, regardless of reputation score. – ajgringo619 Oct 19 at 21:17
  • yes, but this was not my own question... – kamino Oct 20 at 9:16
  • 1
    That helped, but I also used this tutorial for enabling VT: 2nwiki.2n.cz/pages/viewpage.action?pageId=75202968 – Dorijan Cirkveni Oct 22 at 13:23
  • I will add the link in the answer, if I may? The link is much better, than what I wrote. Is the second error-code gone too? – kamino Oct 22 at 18:55
  • 1
    @kamino yes, the second error is gone as well. And yes, you may add it. – Dorijan Cirkveni Oct 25 at 15:22
0

and a command line which I'm not sure what to do with.

You say you have installed "also the .iso"

You can enter the image names and parameters (if needed) at that command line manually - look at what the other menu entries contain (the ones that dont work).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.