0

My Machine dual boots windows 10 and Bunsenlabs. Hard drives are encrypted with VeraCrypt. The second Hard drive became read only now (one internal one external).

Peculiarity

Windows created "$RECYCLE.BIN" and "System Volume Information" folders on both internal and external hard drives. usually I could just delete them under Linux. When I boot into Bunsenlabs and mount the internal hard drive in VeraCrypt, it is read/write. As soon as I touch a single file in those two folders, the drive goes read only. It also goes read only when I backup with backintime.

Things I tried:

  • chmod -R 777 as root
  • Thunar as root
  • mount in VeraCrypt under different path
  • disabled fast startup under windows and rebooted (Linux and Windows)
  • Use a command line tool under windows to delete "$RECYCLE.BIN" and "System Volume Information" folders, I cannot remember which one now

a) How can I make the drive permanently r/w again?

b) how can I get rid of "$RECYCLE.BIN" and "System Volume Information" folders?

0

Today I thought I might as well try windows' own check and recovery tool (right click on hard drive --> tools). And what do you know, it did just that.

Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.