3

I have a new Dell XPS 13 7390 Developer Edition. This is not the 2-in-1 machine; it's the regular laptop which comes with Ubuntu preinstalled. I am trying to install Debian instead of the OEM version of Ubuntu.

I have created a USB drive for installing Debian Buster. I have tested the USB drive using a previous Dell XPS laptop (which has USB-A ports), and it works.

However, when I try to use the same USB drive on the new machine, which only has USB-C ports, I get an Ubuntu splash screen while it loads, followed by the infamous message:

(initramfs) Unable to fnd a medium containing a live file system

I believe the Ubuntu splash screen is because the machine ships with Ubuntu installed, and it was installed with UEFI.

I have toggled all of the relevant BIOS options I can find - "USB Boot Support" and "Enable External USB Ports" are enabled. I've also switched "Enable Thunderbolt Boot Support" on and SATA Operation is on the default setting (AHCI).

I've tried this with two separate USB drives and three different A-to-C USB adapters, including the adapter that came with the laptop. I've also tried it with all three ports (the USB-C port on the right is not a Thunderbolt port, but the two on the left are).

I do not believe this is a problem with the installation media, as I have tried it with multiple USB drives and multiple adapters, and I am able to use one to boot the installation media on a different laptop.

EDIT: I tried it with an Ubuntu 18.04 drive and Ubuntu 19.10 drive as well, and I get the same error message on the new laptop. I'm able to use that same Ubuntu drive to launch the installation process (via UEFI, not legacy BIOS) on the older laptop.

  • 1
    New PC? Contact Dell Support dell.com/support/home/us/en/04?app=products – K7AAY Oct 18 '19 at 17:24
  • 1
    Can you boot that computer from USB drive for installing Ubuntu 18.04.3 LTS or the new Ubuntu 19.10? That way you can try to find out if the problem is a compatibility issue with Debian Buster and your computer (if it works with Ubuntu live), or if it is a problem with the USB C connections or some other thing more directly related to booting from USB. – sudodus Oct 18 '19 at 17:55
  • @sudodus Good question. I tried it with Ubuntu 18.04, and the same issue happens. – chimeracoder Oct 18 '19 at 20:50
  • 1
    What is the graphics chip/card? If nvidia, you can try with the boot option nomodeset. If the computer is very new, it is a good idea to try with the newest possible Ubuntu version, 19.10 released yesterday. It has newer kernel and hardware drivers than 18.04, and is more likely to work with new hardware. – sudodus Oct 18 '19 at 21:27
  • It uses integrated Intel graphics. I tried with 19.10, and I have the same issue. – chimeracoder Oct 18 '19 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.