1

I recently installed Arch on my laptop, and I've been having a problem booting. After the grub screen, it loads up until it says "Reached target Graphical Interface", and then it gets stuck on a black screen with a cursor in the corner. I think it might be a problem with lighten or nvidia, but I'm not entirely sure and I don't know how to approach it. Any help would be appreciated.

Edit: I have a Geoforce GTX1050 graphics card and I tried installing nvidia 435.21 and bumblebee 3.2.1. I've also tried using other display managers, but they all have the same issue. Secure boot is disabled in the UEFI.

I installed the drivers by following the guides on the arch wiki, and bumblebee is enabled and starts fine. lightdm fails to start though.

  • Probably you need drivers for Nvidia. Boot with nomodeset and install them. Also disable Secure Boot in UEFI settings. If this concepts are foreign to you then you shouldn't be using Arch. That distro is not beginner friendly. – user353477 Oct 18 '19 at 2:02
  • I tried that and it didn't work. If any log files are needed, I can provide them. – Australian Ostrich Farmer Oct 18 '19 at 2:12
  • Tried what exactly? Also please edit the question and describe what you tried already, do not just put it in comments. – user353477 Oct 18 '19 at 2:15
  • Thanks, I've edited the post. – Australian Ostrich Farmer Oct 18 '19 at 2:24
  • Thanks but... nomodeset is just a way to have a (basic and low resolution) GUI with certain Nvidia graphics without proprietary drivers and it is to be used until those drivers are installed only. Your edit is nonsensical and doesn't add anything useful for helping you. Please add your hardware specifications (Nvidia), which driver version have installed, where did you get those from and how you installed. – user353477 Oct 18 '19 at 2:30
0

I had a similar problem with a "intel" GPU in arch. No matter how you combine distros, configuration tools and intel, nvidia etc, there is always room for some misconfiguration.

The main configuration file for X's GPU drivers is /etc/X11/xorg.conf. It has a man page, which is actually the main man page for x (man xorg.conf). "Card0" is the default identifier name for the (first) GPU card or chip. Here is what that xorg.conf must contain: actually just the correct Driver:

Section "Device"
        Identifier  "Card0"
        Driver      "intel"  # nvidia also has own drivers 
        #   Driver     "modesetting" ...deactivated 
        BusID       "PCI:0:2:0" # necessary?
EndSection

Arch Linux had left me without any xorg.conf at all, the way I installed. First I got "modesetting" and X wouldn't start, it would just read configfiles and probe some modes and give up with lots of messages. Could be a CRT monitor thing even. I finally just added "intel" as driver and it worked. No trick or hack whatsoever. Somebody just had to tell X. Very simple in the end, and looking back.

So look at your xorg.conf, section "Device", option "Driver". Nvidia is a bit special ("nouveau"?). Probably just takes one line to get right.

I'm assuming you reach some "multi-user" systemd target, a working non-GUI linux console...


Geoforce GTX1050 graphics card

You know your GPU, you know your kernel version and modules, you know when you want to go graphical: so you tell your system which pieces you want. Should be automatic, yes, but this area often needs a push. Arch.wiki should really have up to date info about anything specific on nvidia.

(I am not to talking about real GPU driver problems...GPU drivers are simply the largest chunk in linux kernel source. It's also the most complex "chip" in a consumer system, besides the CPU)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.