3

I have a new laptop on which I have installed Ubuntu 18.04. The laptop has a Realtek RTL8111/8168/8411 ethernet / wifi card. I cannot detect or connect to any wifi networks. I have plugged in a separate USB wifi device and that works fine.

I have tried installing the latest driver (sudo apt-get install r8168-dkms) without success.

The network interface is showing as down and I have been unable to bring it up.

$ lshw -C network

WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: memory:a4300000-a4303fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:08:00.1
       logical name: enp8s0f1
       version: 12
       serial: 80:fa:5b:69:e3:c6
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.045.08-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
       resources: irq:129 ioport:3000(size=256) memory:a4204000-a4204fff memory:a4200000-a4203fff

-

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp8s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 80:fa:5b:69:e3:c6 brd ff:ff:ff:ff:ff:ff

-

This is my default network interfaces

cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

I tried adding the interface and restarting the network-manager.

cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto enp8s0f1
iface enp8s0f1 inet dhcp

But the laptop network-manager failed to reboot in this configuration.

Here is the driver install:

$ sudo apt-get install r8168-dkms 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed
  r8168-dkms
0 to upgrade, 1 to newly install, 0 to remove and 4 not to upgrade.
Need to get 0 B/94.9 kB of archives.
After this operation, 1,224 kB of additional disk space will be used.
Selecting previously unselected package r8168-dkms.
(Reading database ... 149279 files and directories currently installed.)
Preparing to unpack .../r8168-dkms_8.045.08-2_all.deb ...
Unpacking r8168-dkms (8.045.08-2) ...
Setting up r8168-dkms (8.045.08-2) ...
Loading new r8168-8.045.08 DKMS files...
Building for 4.15.0-65-generic
Building initial module for 4.15.0-65-generic
Secure Boot not enabled on this system.
Done.

r8168:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-65-generic/updates/dkms/

depmod...

Backing up initrd.img-4.15.0-65-generic to /boot/initrd.img-4.15.0-65-generic.old-dkms
Making new initrd.img-4.15.0-65-generic
(If next boot fails, revert to initrd.img-4.15.0-65-generic.old-dkms image)
update-initramfs.....

DKMS: install completed.

Any thoughts or help appreciated.

Update: I also just tried building the latest driver from source https://github.com/mtorromeo/r8168

It installed OK, but no change

$ sudo ethtool -i enp8s0f1
driver: r8168
version: 8.047.04-NAPI
firmware-version: 
expansion-rom-version: 
bus-info: 0000:08:00.1
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

-

$ lspci -knn | grep Net -A3
07:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)
    Subsystem: Intel Corporation Device [8086:0084]
08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader [10ec:5287] (rev 01)
    Subsystem: CLEVO/KAPOK Computer RTL8411B PCI Express Card Reader [1558:8552]

-

$uname -a
Linux XXX-NH50-70RH 4.15.0-65-generic #74-Ubuntu SMP Tue Sep 17 17:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
3
  • 1
    Your wifi card is Intel Wi-Fi 6 AX200 , you should upgrade your kernel to 5.1 see wireless.wiki.kernel.org/en/users/drivers/iwlwifi
    – GAD3R
    Commented Oct 17, 2019 at 7:54
  • 1
    Related unix.stackexchange.com/questions/518571/…
    – GAD3R
    Commented Oct 17, 2019 at 7:56
  • 1
    Thanks, this worked. I upgraded the kernel to 5.1 and installed the intel driver. When I access the login screen I can see the wifi is working. The bad news for me is that I can't boot into the desktop - I think because my nvidia drivers are incompatible with the kernel, but thats another problem. If you want to add an answer I can accept it.
    – F_SO_K
    Commented Oct 17, 2019 at 8:48

2 Answers 2

2

Your wifi card is Intel Wi-Fi 6 AX200 . You need to upgrade your kernel to 5.1.

wireless-wiki-kernel and Linux* Support for Intel® Wireless Adapters

The following devices are supported (since kernel version):

Wi-Fi 6 products

   Intel® Wi-Fi 6 AX200 (5.1)

To upgrade your kernel you can use the ukuu tool:

sudo add-apt-repository ppa:teejee2008/ppa
sudo apt install ukuu

use ukuu --list to list the available kernel , see ukuu --help.

1

I had some problems with upgrading my kernel due to other drivers (probably Nvidia) being incompatible with kernel 5.x. In the end I found that Intel have released a backport driver that is compatible with my current kernel.

sudo add-apt-repository ppa:canonical-hwe-team/pc-oem-dkms
sudo apt-get update
sudo apt-get install backport-iwlwifi-dkms
reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .