0

So, I am having an issue where my Ubuntu Server (v18.04.3) no longer wants to connect to the internet. It was working fine before I took out my gpu to sell. I have googled to my hearts content and have found many people with the same or similar issues. I have tried all the remedies that have been suggested, but to no avail. Could someone give me a bite more insight as to how I might fix this?

Links I have tried:

Outputs from commonly asked commands:

  • ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 1000 (Local Loopback)
        RX packets 2160 bytes 154368 (154.3 KB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 2160 bytes 154368 (154.3 KB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions0
  • ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_left forever
    inet ::1/128 scope host
       valid_lft forever preffered_left forever
2: enp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether d8:cb:8a:bf:3c:af brd ff:ff:ff:ff:ff:ff

EDIT: Spelling/grammar

  • Instead of the old /etc/network/interfaces, Ubuntu 17.10 and newer are using netplan for their network configuration storage by default. Is there a file named like /etc/netplan/*.yaml in your system? What is in it? – telcoM Oct 16 '19 at 16:02
  • Yes, there is, and I have renamed the enpXs0 (X being a number that I changed to see if it would work). Unfortunately, that did not show any results. – ToastyNikk Oct 16 '19 at 16:52
  • This is what was inside it 'network:' 'ethernets:' 'enp6s0:' 'dhcp4: true' 'version: 2' Pastebin: pastebin.com/jLUE0Q9f – ToastyNikk Oct 16 '19 at 18:15
0

When you removed the GPU, the PCIe bus configuration of your system changed, causing the bus location of your NIC to change. This change is reflected in the PCI IDs in the lspci listing, and also in the "predictable network interface names".

Your NIC used to be named something like enp?s0; now it is enp6s0.

Edit the netplan YAML file to change the name of the NIC to match what it is now:

sudo nano /etc/netplan/*.yaml

Change enp?s0 (where ? is some number unknown to me) to enp6s0 and press Ctrl+X to save & exit.

(Based on your comments, perhaps you have already done this.)

Then run sudo netplan apply. (This might be the only thing you're missing.)

  • Yea, I kept editing and rebooting the server since it doesnt take so long. I didnt try the sudo netplan apply, so maybe that will fix it. – ToastyNikk Oct 16 '19 at 17:03
  • I have now tried this method and it does not work, I am still unable to connect to the internet. – ToastyNikk Oct 16 '19 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.