1

I have downloaded kali from the official page, version large 64bit, after installation it doesn't show GUI. First, it shows all checks (I haven't seen any error there tho), after that it seems like it hangs out(?). I managed to go to console mode using ctrl+alt+F2. startx is undefined, X throws some strange content, gdm3 hangs. Tried running apt-get update / apt-get upgrade / apt update / apt upgrade, installing gnome, gdm3, kali-linux-full, rebooting. And still no gui. Switching ctrl+alt+F2 -> ctrl+alt+F1 gives me black screen with _ on top, can't type anything there.

The card is a NVIDIA GeForce GTX 1660 Ti.

Any idea what should I do? Reinstall linux (tried), redownload it on USB, use other kali distribution? (Using rufus to create bootable USB)

enter image description here enter image description here

Tried to add nomodeset: enter image description here

  • 1
    Do you need to install it? Maybe it works well enough live or persistent live from a USB drive (pendrive or external SSD). – sudodus Oct 16 at 13:00
  • 1
    Because of the nvidia card, try with the boot option nomodeset. – sudodus Oct 16 at 13:24
  • 1
    Well, it seems from the screenshots that you have problems with the graphics. Kali is based on Debian, and the newest stable version is 10 'Buster'. Please try if you can boot Debian 10 live and/or install it and get the graphics working. You can add nomodeset temporarily at grub (if UEFI mode) or at syslinux (if BIOS mode) just for testing. – sudodus Oct 16 at 14:16
  • 1
    So it is a general problem with Debian 10 and the re-spin distros based on Debian 10. They cannot manage your computer. Let us hope that someone will chip in and suggest what to do to solve the problem. Maybe you have to try with another linux distro, for example Ubuntu, but if you want Kali because of its pentesting features, you have to wait ... or try with another computer, and it is more likely that you succeed in an old computer or a computer with simple built-in (Intel) graphics. – sudodus Oct 16 at 15:20
  • 2
    I have managed to solve this problem @sudodus. apt install nvidia-driver and rebooting after this worked (also ran apt upgrade but probably it didn't do that much) – kmdrGroch Oct 22 at 13:14
3

The solution to this problem seemed to be as easy as installing a package, specifically: apt install nvidia-driver and rebooting after this. GUI appeared and worked nice and smoothly

  • Thanks for sharing your solution :-) – sudodus Oct 22 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.