1

My laptop's SD card reader is recognized by Linux (OpenSUSE Tumbleweed) as "RTS525A PCI Express Card Reader", yet it is not visible by the system when I insert an SD card (tried it with SD cards of different sizes, including sizes less than 1 GB). I think if it worked and I could mount it, I could see something like mmblkXXXX with this command:

int@linux-pc54:~/Downloads> ll /dev | grep mm
crw-------   1 root root       10, 165 Oct 13 03:59 vmmon

which doesn't happen.

So I'm wondering if there is a solution to this. Would appreciate some help. I've also tried it with Megeia 7 an the latest CentOS 7 (including CentOS Stream), to no avail.

21
  • Could you post the output of dmesg and lsblk (relevant parts) after inserting a card?
    – rudib
    Oct 13, 2019 at 12:08
  • It would need the driver enabled too: cateee.net/lkddb/web-lkddb/MISC_RTSX_PCI.html . The option changed name after 4.15, maybe the distribution didn't notice?
    – A.B
    Oct 13, 2019 at 14:32
  • @A.B It doesn't seem that it is described on that page how to enable that driver.
    – sequence
    Oct 14, 2019 at 2:45
  • 1
    @sequence apparently, you are supposed to use rtsx_usb: forums.debian.net/viewtopic.php?f=7&t=124956#p595032
    – rudib
    Oct 15, 2019 at 8:56
  • 1
    Maybe remove rtsx_pci by running modprobe -r rtsx_pci and then insert rtsx_usb? And maybe also check dmesg after doing that.
    – rudib
    Oct 15, 2019 at 15:56

1 Answer 1

0

Check if rtsx_pci might be blacklisted. Since that can happen in different ways a fulltext search of your module name across /etc is your best bet.

grep -r rtsx_pci /etc

I found my blacklist entry in /etc/modprobe.d/blacklist-rts5227-dkms.conf my Arch Linux system with Kernel 6.1 but I'm not exactly sure how it got there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .