according to redhat link:


we can see that - Chrony on RHEL7.2 can sync to windows ntp server, But Chrony on RHEL7.4 can't sync it.

in my case we have redhat 7.5

how to know if the problem with chrony is the same also on redhat 7.5 or maybe already solved ?

1 Answer 1


This issue is not considered to be a bug with chrony, so the chrony package on RHEL 7.4 and above will exhibit the same behaviour.

The root cause of the problem is that chrony considers the time reported by the Windows Server to be inaccurate. According to the this solution article, the problem occurs with Windows versions earlier than Server 2016 that use their local clock as the reference.

This gap exists because the Windows Time service was originally created to ensure that systems using Active Directory could be kept in sync with a variation of up to 5 minutes. It was not meant to be used as a fully-fledged NTP solution - source. Windows Server 2016 includes updates to support high-accuracy timekeeping, but the default settings remain the same.

The solution to the problem is to make the time source more accurate. If you have Windows Server 2016 or later, you could look into the high-accuracy timekeeping settings. Otherwise, you could have the Windows Server connect to a different NTP server for synchronization instead of using its local clock.

  • how you know that problem is relevant until WIN 2016 ? ( I not see note about it in the post - access.redhat.com/solutions/3425701 )
    – yael
    Oct 13, 2019 at 5:12
  • any way do you suggest to move to ntp service incited chorny service ?
    – yael
    Oct 13, 2019 at 6:30
  • @yael 1) That solution article (3425701) has a link to the one I've provided in my answer (23365). The latter contains more details, an in-depth analysis, and links to Microsoft docs. 2) Chrony is the preferred NTP service on RHEL 7. See this URL for details.
    – Haxiel
    Oct 13, 2019 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.