6

I cannot seem to get CentOS 8 to run full screen in VMware Workstation. Additionally, there doesn't seem to be an appropriate resolution under display settings. I've tried uninstalling and re-installing open-vm-tools (10.3.0.5330 (build-8931395)) as well as installing vmware-tools (10.1.6 (build-5214329)) from VMWare Workstation.

Under VMware Workstation > View options, Autosize is set to Autofit Gues. The "Fit Guest Now" and "Fit Window Now" are grayed out. I've also tried setting the VM display settings from "Use host setting for machines" to "Specify monitor settings" to no avail.

Using VMware Workstation 12 Pro 12.5.9 build-7535481 CentOS Linux release 8.0.1905 (Core)

4
  • You probably need to update to a more recent version of VMware Workstation.
    – fpmurphy
    Oct 10, 2019 at 2:27
  • I've upgraded to VMware Workstation 15 Pro (15.5.0 build-14665864) and the problem persists. Oct 28, 2019 at 19:39
  • I ran into the exact same problem just now with VMware Workstation 15.5 and CentOS 8 (Build 1905)
    – fpmurphy
    Oct 29, 2019 at 1:51
  • Problem still occurs if you remove open-vm-tools and install VMware Tools
    – fpmurphy
    Oct 29, 2019 at 3:12

4 Answers 4

3

I think the issue may have to do with this:

In Red Hat Enterprise Linux 8, you can choose between two protocols to build a graphical user interface:

  • X11
  • Wayland

[...]

  • Due to stability issues, using X11 instead of Wayland is recommended in virtual environments.

Source: Red Hat Enterprise Linux/8/Using the desktop environment in RHEL 8/Chapter 2. Displaying graphics

Basically, when you start your VMware virtual machine and arrive at the login screen, by default, if you login, it uses Wayland to build the GUI. You have to change it to X11 by clicking on the gear/cogwheel icon beside the "Sign in" button, as described in the documentation on the link below.

Source: Red Hat Enterprise Linux/8/Using the desktop environment in RHEL 8/Chapter 1. Starting using GNOME

You may then set the display resolution and it will save the settings even after rebooting.

1

Use: sudo yum install xorg*vm*

The Packet xorg-x11-drv-vmware is what you need.

DO NOT USE : sudo yum install "xorg\*vm\*" YOU WILL GET NOTHING!!

0

It's actually a combination of two previous answers. Choose X11 on the logon screen AND sudo yum install xorg-x11-drv-vmware. Just make sure you sudo yum upgrade before that, so everything is consistent. Got myself a nice "Oops something went wrong from Gnome for ignoring that last advice. Also with VMware Workstation going from open vmware tools to the real thing made a lot of things better, especially suspending the client (CentOS 8) operating system and waking it up again.

-1

I'm using VMware Workstation 14 Pro (14.1.7 build-129899930), but I pulled down the latest CentOS 8 ISO today and did the following (inside the CentOS VM):

  1. Activities > Show Applications > Settings > Search > Displays > Resolution > 1920 x 1200 > Apply > Keep Changes

Bear in mind, these settings will not persist after a restart. To persist your resolution settings, you'll need to do something like this.

3
  • Can you check if you have an option of going 1920x1080. My CenOS 8 guest on VMware Workstation 15 Pro doesn't show that despite being my monitors default resolution.
    – kmpm
    Oct 28, 2019 at 10:18
  • Like kmpm, my host resolution is 1920x1080. There is no resolution in CentOS guest for 1920x1080. I can set the resolution to 1920x1200 like you've specified and then set "View > Stretch Guest" in VMwrare but this is not ideal. Oct 28, 2019 at 20:01
  • This workaround does not work with VMW 15.5
    – fpmurphy
    Oct 29, 2019 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .