I'm trying to update my Ubuntu 18.04 computer that does not have internet connection. However the process is failing when I try to run sudo apt upgrade. I have checked a couple of other links like: sol1, sol2 and sol3.

I have set up apt-offline on my offline computer we can call OC1, and I have also set it up on my online computer we can call OC2. I set up a signature file on my OC1, I then bring the file over to OC2, and use the command sudo apt-offline get apt-offline.sig --bundle apt-offline-update.zip. It downloads all the packages to that zip file and I then bring that file over to OC1.

Great at this point everything is normal and running as I expect it to. Now I install the package with this command: sudo ./apt-offline install /home/fletchy/Desktop/MyPC/apt-offline-update.zip I select Yes (Y) when prompted to install and it installs the packages. However it just syncs them all. However I suppose that make sense because now I would just do a normal sudo apt upgrade and I'll update and I'll be good to go. However, when I run sudo apt upgrade it runs as if its looking at the internet to install these packages not my cache or directories.

I get errors like:

Err:## http://... Could not resolve 'us.archive.ubuntu.com'
E: Failed to fetch http....deb Could not resolve 'us.archive.ubuntu.com'

What I would expect to get is a successful install of the packages and update of the system. Perhaps I'm missing something small, I've used Linux for awhile now but never had to update packages offline until recently and I'm encountering this problem. I've attempted to reboot the system, and restart the entire update process from scratch.

Edit 1:

I just noticed that when I run apt-cache show I get the following response: E: No packages found


I have found a solution, there may be a better one but this worked for me...

Part 1

Instead of doing: sudo apt upgrade by itself you have to use the tag --fix-missing and it will fail at first but then discover all the packages you set up using the normal method of apt-offline and it will update as expected.

Short story use this command: sudo apt upgrade --fix-missing

Part 2

Now if your trying to install packages/products/modules so things like net-tools for example... you do everything the same except...

Dont use: sudo apt upgrade --fix-missing, use: sudo apt-get install net-tools

| improve this answer | |
  • However it still seems to be failing with some update packages in Part 1... not sure why, perhaps someone could elaborate. – Fletchy1995 Oct 10 '19 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.