0

Symptoms: Audio (system-wide, not software specific) is occasionally interrupted (and when silent, a popping sound can be heard) every 10-20 seconds.
When observed through pavucontrol or similar tools, it can be seen that the port switches from Line Out to Headphone for a few milliseconds.

Troubleshooting: Unsure, past research (a year ago, links lost) lead to some very old kernel bug, but really I can't remember much. For me, it occurs on all distributions I tested (Mint, Kubuntu and now Manjaro), but not Windows.
Seems like the Headphone port is shortly recognized, pulseaudio (or alsa, not really sure) decides to switch to headphone, only for it to revert back immediately after the glitch reverts.

Workaround: Worked for the past year without a problem - it's probably not fixing the source problem. Will post it as a self-answer for now.

Any input as to how the source problem could be fixed are appreciated.

1 Answer 1

0

Workaround
Find the conflicting port, and disable it.
enter image description here
This can be done with HDAJackRetask - select the correct sound card / codec (e.g. Realtek ALC892), find the conflicting port/pin (e.g. 0x1b) and override it to 'Not Connected'. Then hit 'Apply Now'.

If an error pops up that says 'Device or resource busy' you'll need to temporarily disable pulseaudio completely. Depending on the circumstances, this will work:

  1. Try simply killing and restarting - pulseaudio --kill and afterwards pulseaudio --start
  2. If PulseAudio automatically respawns, tell it to not spawn automatically again
  3. If that doesn't work, you might need to disable the systemd service shortly (and start again by replacing stop with start)

After that is done, you might want to hit 'Install boot override' so that the fix is applies on the next restart as well. Only do this once you are sure it works of course.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .