0

Failing to install Python 3.6 on CentOS. The error message is : Error: Package: python36-libs-3.6.8-2.el7.ius.x86_64 (ius) Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)

These library packages already exist on this machine:

libcrypto.so.10()(64bit) libcrypto.so.10(OPENSSL_1.0.1)(64bit) libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) libcrypto.so.10(libcrypto.so.10)(64bit) libcrypto.so.10 libcrypto.so.10(OPENSSL_1.0.1) libcrypto.so.10(OPENSSL_1.0.1_EC) libcrypto.so.10(libcrypto.so.10)

  • You are missing OpenSSL v1.0.2, it seems that you have OpenSSL v1.0.1 installed. Have you tried upgrading OpenSSL? OpenSSL v1.0.2k is available for CentOS 7, yum install openssl should upgrade it. – GracefulRestart Oct 4 '19 at 22:15
  • Sir, I tried yum install openssl this is what I got : Loaded plugins: fastestmirror, rhnplugin This system is receiving updates from RHN Classic or Red Hat Satellite. ius | 1.2 kB 00:00:00 Loading mirror speeds from cached hostfile Package 1:openssl-1.0.1e-60.el7_3.1.x86_64 already installed and latest version Nothing to do – KudmiSubba Oct 6 '19 at 7:16
  • From that output, it appears you are trying to use RedHat repositories which would require a subscription. If you are using CentOS and not RedHat, do you have access to the Base repository? What is the output of yum repolist? – GracefulRestart Oct 6 '19 at 15:40
0

I suggest that you disable the IUS repository that is providing the python36 packages. Python 3.6 is provided by CentOS's base repositories in the python3 packages, as of CentOS 7.7.

| improve this answer | |
  • Pre CentOS 7.7 there are other ways to get python 3.6 such as miniconda or conda, or compile from source, but if you can, just upgrade to 7.7 and you should be able to run "yum install python3" – Brandon Zappy Oct 5 '19 at 23:03
  • Sir, Thank you all for your advise. I will try it tomorrow and get back to you. – KudmiSubba Oct 6 '19 at 1:21
  • I tried yum update --disablerepo=ius_x86/64 and then ran yum install python3 i get the following : epel: reflector.westga.edu No package python3 available. I have to try building the sources now, but is there anything else I can try. Thank you for your help. – KudmiSubba Oct 6 '19 at 7:32
  • @KudmiSubba do you have any of the CentOS repos enabled? – jsbillings Oct 6 '19 at 14:13
0

I thank all of you for your help and sorry for the delay. Finally I was able to solve it by first uninstalling OpenSSL v1.0.1. @GracefulRestart - the yum update did not work. I wanted to share this information so that it could help others.

I then installed only OpenSSL v1.0.2 . Then I was able to follow the rest of the steps from the Python website to install 3.6 and also install the latest pip.

Thank you very much.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.