1

The way I'm installing the DEs:

XFCE:

apt install -y xfce4

KDE:

apt install aptitude tasksel
aptitude install ~t^desktop$ ~t^kde-desktop$

Both seem to prompt for a selection for the language/keyboard halfway through. Is there an option to make it auto-select default and proceed?

0
3

Use the noninteractive debconf frontend:

export DEBIAN_FRONTEND=noninteractive
apt install -y xfce4

This will prevent the packages from asking questions, and the defaults will be chosen.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.